Re: [gembud] Invalid device selected

Hi Jacob,

So the thing about x-windows and the DISPLAY environmental variable is
this:  When Gempak tries to make an image, it needs a place to open up and
present that image before saving it.  Say you open an image file on your
PC, that image opens up in a window right?  That's basically what Gempak is
trying to do.  But I think most of us are running Gempak in a server
environment, where there is no desktop and therefore no direct way to just
open a window.  That's what x-windows does for us, it gives software like
Gempak a place to virtually open a window so that image can be created, and
then ultimately saved as an image file.  Xvfb is a piece of Linux software
that can host these "virtual desktops" and the DISPLAY environmental
variable is how we can tell our Gempak scripts which one to use.  I think
there are other ways of doing this without the use of Xvfb, it's just what
I'm used to.

All that being said, I've been doing a little checking this morning trying
to recreate your issue.  If I try to set DISPLAY to something I know won't
work, I get the following error:  "[GEMPLT -83]  NDISP - DISPLAY not set or

But that's not your error.  Yours is:  "[GEMPLT -21]  NODEVC - Invalid
device selected"

If I change my device line to something I know won't work (DEVICE =
asdf|test.gif|1000;1000), then I'll get your "[GEMPLT -21]" error.

What this is telling me is devices that should be working for you aren't.
It's not that Gempak can't find an x-window like I first suspected, it's
more like Gempak can't find the right device drivers.  I'm beginning to
wonder if something's wrong with your Gempak installation.  You said before
you haven't tried any other Gempak programs, has anything Gempak worked for
you on this installation?  Is the Gemenviron or Gemenviron.profile file
getting sourced?  And what OS is all this taking place on, and is it a
server or desktop environment?


Mike Zuranski
Meteorology Support Analyst
College of DuPage - Nexlab <>

On Wed, Jul 17, 2019 at 6:19 PM JACOB WIESE <jake9wi@xxxxxxxxxxx> wrote:

> OkyDok; I tried  '/home/jacob/sfc.gif'  same results.
> Here is my latest script revision.
> #!/bin/bash
> cd /home/jacob/
> export DISPLAY=":0.0"
> gpfront <<EOF
> MAP    = 0
> GAREA  = us
> PROJ   = CED
> LATLON = 2/1/1
> PANEL  = 0
> TITLE  =
> TEXT   =
> CLEAR  = N
> DEVICE = gif | /home/jacob/sfc.gif | 1000;1000
> ASFIL  = asus1.txt
> ASHR   = 0
> ASATT  =
> r
> e
> gpend
> ###
> =-=-=-=
> 73s
> Signed/KD9LWR/Jacob-E-Wiese/Cell-219-221-0486//
> PGP-KEY-ID/0x5DC8AC4F5C0330B1//
> ________________________________________
> From: Mike Zuranski <zuranski.wx@xxxxxxxxx>
> Sent: Wednesday, July 17, 2019 18:03
> Cc: gembud@xxxxxxxxxxxxxxxx
> Subject: Re: [gembud] Invalid device selected
> Okay, thanks for trying that. I just noticed your output file name
> "~/sfc.tiff" is a relative path.  Try an absolute path and see if that
> works.  If not, I can try to give you more advice about x-windows later
> (have to run out the door for now).  But this would be an easy thing to
> test first.
> Sorry you're running into issues, hopefully we can get things working for
> you.
> -Mike
> ======================
> Mike Zuranski
> Meteorology Support Analyst
> College of DuPage - Nexlab
> ======================
  • 2019 messages navigation, sorted by:
    1. Thread
    2. Subject
    3. Author
    4. Date
    5. ↑ Table Of Contents
  • Search the gembud archives: