[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[netCDF #WZP-605301]: NetCDF installation error



Hello,

Unfortunately, netCDF 3.6.3 is quite old and not currently supported.  I am 
also not able to install it on OSX Mojave.  You may need to reach out to the 
ROMS maintainer and ask if they have updated instructions for a modern version 
of netCDF (current version is netCDF 4.7.1 for the core C library, and netCDF 
4.5.2 for the Fortran interface).

I'm sorry I can't provide a more immediately actionable solution, but I hope 
this helps.

Have a good day,

-Ward

> Dear Sir/Madam,
> I am trying to install ROMS on macOS Mojave, I followed the steps provided
> on WikiROMS at https://www.myroms.org/wiki/ROMS_Mac. I installed the
> Supporting Software [ Xcode, GNU Fortran Compiler(gfortran-4.2.3, GNU
> Make(make-3.8.1), Perl ] but while installing NetCDF3.6.3 I got an error
> message like --- Error checking if Fortran "byte" is C "signed char"...
> configure: error: Could not link conftestf.o and conftest.o--- in the
> ./configure step. Please help. If any other information is needed please
> let me know.
> 
> --
> *???????,*
> *Thank you*
> *With Regards,*


Ticket Details
===================
Ticket ID: WZP-605301
Department: Support netCDF
Priority: Normal
Status: Closed
===================
NOTE: All email exchanges with Unidata User Support are recorded in the Unidata 
inquiry tracking system and then made publicly available through the web.  If 
you do not want to have your interactions made available in this way, you must 
let us know in each email you send to us.



NOTE: All email exchanges with Unidata User Support are recorded in the Unidata inquiry tracking system and then made publicly available through the web. If you do not want to have your interactions made available in this way, you must let us know in each email you send to us.