Re: [thredds] THREDDS & WCS

Hi John:

I am having problems with WCS as we are testing 3.16.19. We made the changes in the thredds config file, so the service is running, and I get a return on the getcapabilities request, but it doesn't contain the coverage itself and therefore all other requests break down. Has the info that needs to be in the catalog.xml changed. It would seem so if I compare: ConfigCatalogs.html


It is unclear on the last page which that info is required.



On Oct 8, 2007, at 4:48 PM, John Caron wrote:

My apologies, this was poorly documented.

WCS is turned off by default for security reasons, and must be turned on in the threddsConfig.xml file:

    <scour>15 min</scour>
    <maxAge>30 min</maxAge>

This page has been updated now:

which references: ThreddsConfigXMLFile.html#WCS


Rochelle.O'Hagan@xxxxxxxx wrote:
Hi John,

I had set up the catalog differently. I have now changed it to what you advised, but still get the "The requested resource () is not available."

I can get coverages back from, but not from the
server I set up for testing. Is this likely to be something wrong with my setup of the server? Does the WCS part of the THREDDS server require
the netCDF subset service, OpenDAP server or nj22? I notice that the
<nj22Config> element is commented out in the threddsConfig.xml file.

Thanks for your help,

Rochelle O'Hagan

-----Original Message-----
From: John Caron [mailto:caron@xxxxxxxxxxxxxxxx]
Sent: Wednesday, 3 October 2007 2:52 AM
To: O'Hagan, Rochelle (CLW, Black Mountain)
Cc: thredds@xxxxxxxxxxxxxxxx
Subject: Re: [thredds] THREDDS & WCS

Hi Rochelle:

Rochelle.O'Hagan@xxxxxxxx wrote:
Hi All,

I'm just starting to use THREDDS (v3.16) and am having problems using
the WCS functionality. I can make GetCapabilities & DescribeCoverage
requests successfully, but can't get GetCoverage to work at all.

I've tried with the example data (testData & wcsExample) and with a
catalog I've set up myself, but always get back a message "The
resource () is not available."

I'm new to all this sort of thing, so is there something I'm missing?
The GetCoverage request is below:

http://localhost:8080/thredds/wcs/galeon/ request=GetCoverage&ve rsion=1.0.0&service=WCS&coverage=u_sfc&format=GeoTIFF&time=2005-03-17 T00

where did you get that URL?

im guessing it should be:

  http://localhost:8080/thredds/wcs/galeon/testdata/ etc

thredds mailing list
For list information or to unsubscribe, visit: http://

"The contents of this message do not reflect any position of the U.S. Government or NOAA."
Roy Mendelssohn
Supervisory Operations Research Analyst
Environmental Research Division 
Southwest Fisheries Science Center
1352 Lighthouse Avenue
Pacific Grove, CA 93950-2097

e-mail: Roy.Mendelssohn@xxxxxxxx (Note new e-mail address)
voice: (831)-648-9029
fax: (831)-648-8440

"Old age and treachery will overcome youth and skill."

  • 2007 messages navigation, sorted by:
    1. Thread
    2. Subject
    3. Author
    4. Date
    5. ↑ Table Of Contents
  • Search the thredds archives: