Re: [gembud] Gempak questions from a newcomer

Usually when we get the "Error in message send" it's because improperly
or non-terminated gempak processes have used up all the available
message queues.  After using anything that creates a plot, you have to
issue a gpend to complete the process or the message queue will be left
in use and the plot may be incomplete.  If you're out of message queues,
you won't even be able to start a plot.

1)  look at your process list for gempak (gp/gd) processes and kill them
2)  use the message queue commands:  ipcs -qa will provide a list of
message queues under "Message Queues", ipcrm -q msqid (where msqid is
the id number) will remove the queue

Depending upon your os you can usually change the number of available
message queues, by default redhat starts with 8 I believe. 

On 3/31/2010 6:16 PM, Jeff Lake - Admin wrote:
> I just discovered the same error's on my GEMPAK servers..
> is related to GCLEAR, I removed that from my scripts
> and all is happy again
> I ran the 'cleanup' after I removed GPCLEAR ..
> or
> in your testing you have some sort of an error that GPEND
> is not stopping the GP.. process allowing your process's
> to get overloaded ..
> Jeff Lake K8JSL
> ----- Original Message ----- From: "~Stack~" <>
> To: <gembud@xxxxxxxxxxxxxxxx>
> Sent: Wednesday, March 31, 2010 5:50 PM
> Subject: [gembud] Gempak questions from a newcomer
> Hello everyone!
> I am a server systems guy and on Monday those in higher positions then I
> informed me that the weather guys were going to start using the cluster.
> Horray! I like a good workload on my cluster (and I have heard tale of
> weather code bringing clusters to their knees). So my response was
> 'Bring it on!' to which they added "And they need you to learn their
> math and software starting with Gempak." Err...
> So I am completely new to all this. I had some issues trying to compile,
> but thanks to previous messages on this list I was able to work my way
> through the compile, but I couldn't get through the tutorial without
> some strange errors and files being missing. Fortunatly one of our tests
> systems is a CentOS 5.4 64bit box so thanks to Jeff Lake[1] I was able
> to get it installed (a newer/latest version to boot!).
> [1]
> Now I am slowly working my way through the tutorials that are posted
> online hoping to gather as much information as I can. I don't have a
> clue what these numbers mean nor the math behind them, but I concider
> myself making progress as long as the tutorial numbers match mine.
> However, I have hit a few snags and would greatly appreciate any
> pointers that allow me to move forward.
> 1)
> Everything goes well up to the run command. All my numbers and outputs
> match. When I give the run command I get:
> [GDLIST -3]
> Error in message send = 22
> itype, ichan, nwords,0,65536,3
> and it dumps me back out to the bash command line...
> I have found others with this error, but so far none of their fixes work
> for me.
> 2)
> "You may not need to restore the defaults file, if you do, you'll find
> it in $GEMPAKHOME/restore/sflist.nts. "
> It gave me an error saying "The save file is invalid."
> I found this and used it instead: "$GEMPAKHOME/defaults/sflist.nts".
> Seems to work, is this a typo in the tutorial or a missing package on my
> end?
> 3)
> Again, everything goes well until I try to run it at which point I get:
> [SFMAP -3] Fatal error initializing GEMPLT.
> Error in message send = 22
> itype, ichan, nwords,0,65536,3
> I found this email[2] which is a similar error with the reply basically
> saying to check my variables.
> [2]
> $echo $DISPLAY
> localhost:0.0
> $echo $GEMEXE
> /usr/local/lib/gempak/NAWIPS/os/linux64/bin
> And yes, I have been running GPEND to clean up after each failed attempt.
> At first I thought this was a problem due to me launching an xterm over
> an ssh connection. So I went and sat down on the box host display itself
> (localhost:0.0) and yet I still got the error. The box has a monster
> NVidia GT200 graphics card in it that works really well so I am pretty
> certain the video card itself isn't the problem. Concidering how new I
> am to all this (gempak) I wouldn't put it past being a configuration
> step I missed; I just am not finding which one. I even went down the
> list and tried each and every one of the display drivers; each one gave
> me the same error.
> I would appreciate any feedback or help. I am currently just going
> through the tutorials on site one-by-one so if you know
> of another good tutorial I should look at, I would appreciate a link.
> Thanks everyone!
gembud mailing list
For list information or to unsubscribe,  visit:

> _______________________________________________
> gembud mailing list
> gembud@xxxxxxxxxxxxxxxx
> For list information or to unsubscribe,  visit:

Christopher Lauer
Meteorologist / Programmer
National Hurricane Center

  • 2010 messages navigation, sorted by:
    1. Thread
    2. Subject
    3. Author
    4. Date
    5. ↑ Table Of Contents
  • Search the gembud archives: