Re: [gembud] Gempak questions from a newcomer

Hash: SHA1

Thanks for all of the responses!

Chris Lauer wrote:
> Usually when we get the "Error in message send" it's because improperly
> or non-terminated gempak processes have used up all the available
> message queues.  After using anything that creates a plot, you have to
> issue a gpend to complete the process or the message queue will be left
> in use and the plot may be incomplete.

I have been doing `gpend; cleanup -c` after each test.

> 1)  look at your process list for gempak (gp/gd) processes and kill them
> 2)  use the message queue commands:  ipcs -qa will provide a list of
> message queues under "Message Queues", ipcrm -q msqid (where msqid is
> the id number) will remove the queue

I had not discovered these commands yet. I will look into them right
away and see what they turn up.

> On 3/31/2010 6:16 PM, Jeff Lake - Admin wrote:
>> I just discovered the same error's on my GEMPAK servers..
>> is related to GCLEAR, I removed that from my scripts
>> and all is happy again
>> I ran the 'cleanup' after I removed GPCLEAR ..

I apologize if I am overlooking something simple, but I am not sure what
script you removed. I did a find on gpclear and all I found was the
binary and related documentation.

I followed the link you provided and I noticed when I ran the sfmap
example that I too had "[GEMPLT -101]  NOPROC - Nonexistent executable".
I just hadn't noticed it before. The link you provided says that the
error is due to the program not being able to talk to gplt. However,
when I run `ls $GEMEXE/gplt` it returns information about gplt. So I
don't think the path is screwy. It may indeed not be seen, but I don't
known if it is the path. Every time I check the path it returns the
'right' information. 'Right' being at least what I *think* it should be;
I am using the information I found online as well as Michael's paths
below as guidelines for how my paths should line up.

Michael James wrote:
> The error message
> Fatal error initializing GEMPLT.
> usually indicates that the executable directory $OS_BIN is not in the
> $PATH - verify that you sourced $NAWIPS/Gemenviron and the
> environmental vars are present ("env"):
> NAWIPS=/home/gempak/GEMPAK5.11.4
> GARPHOME=/home/gempak/GEMPAK5.11.4/comet/garp
> GARP_PATH=/home/gempak/GEMPAK5.11.4/comet/garp/config
> NA_OS=linux64
> GEM_COMPTYPE=gfortran
> GEMPAK=/home/gempak/GEMPAK5.11.4/gempak
> GEMPAKHOME=/home/gempak/GEMPAK5.11.4/gempak
> CONFIGDIR=/home/gempak/GEMPAK5.11.4/config
> OS_ROOT=/home/gempak/GEMPAK5.11.4/os/linux64
> OS_BIN=/home/gempak/GEMPAK5.11.4/os/linux64/bin
> OS_INC=/home/gempak/GEMPAK5.11.4/os/linux64/include

Thanks for the help everyone!
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla -


  • 2010 messages navigation, sorted by:
    1. Thread
    2. Subject
    3. Author
    4. Date
    5. ↑ Table Of Contents
  • Search the gembud archives: