Re: [thredds] Thredds Opendap Service ascLimit and binLimit

Hi Ethan,

Thank you for your reply.

I am currently running Version 4.1.20100520.1554 - 20100520.1554

I have tested serving a dataset which is about 81576444 (<80mbs) and I still 
get that error.


Derrick Wong 
Software Engineer | ASRDC (Australian Spatial Research Data Commons) Project | 

Phone: +61 8 6436 8945
derrick.wong@xxxxxxxx |
Address: ARRC (Australian Resources Research Centre), 26 Dick Perry Avenue, 
Kensington WA 6151, Australia

The information contained in this email may be confidential or privileged. Any 
unauthorised use or disclosure is prohibited. If you have received this email 
in error, please delete it immediately and notify the sender by return email. 
Thank you. To the extent permitted by law, CSIRO does not represent, warrant 
and/or guarantee that the integrity of this communication has been maintained 
or that the communication is free of errors, virus, interception or 
Please consider the environment before printing this email.

-----Original Message-----
From: thredds-bounces@xxxxxxxxxxxxxxxx 
[mailto:thredds-bounces@xxxxxxxxxxxxxxxx] On Behalf Of Ethan Davis
Sent: Thursday, 26 August 2010 2:32 AM
To: thredds@xxxxxxxxxxxxxxxx
Subject: Re: [thredds] Thredds Opendap Service ascLimit and binLimit

Hi Derrick,

The change you made looks like it should have fixed the problem. A
restart of the TDS should be enough for the changes to take affect. (Of
course, restarting Tomcat will work as well.)

What version of the TDS are you running?

In case it isn't clear, the OPeNDAP size limits do not affect the size
of the datasets that can be served only the size of the data that can be
accessed in a single request. So, if you run into this limit, you can
also try to request a smaller subset of the data.


On 8/25/2010 3:20 AM, Derrick.Wong@xxxxxxxx wrote:
> Hi all,
> I am currently trying to serve datasets using Opendap
> (via thredds) and some of my datasets are bigger than
> the default sizes (50asc/500bin)
> I have tried configuring it in threddsConfig.xml but
> I am still
> Getting the following error on my browser:
> Error {
>     code = 403;
>     message = "Request too big=81.0 Mbytes, max=50.0";
> };
> Despite specifying the following:
> <Opendap>
>     <ascLimit>500</ascLimit>
>     <binLimit>500</binLimit>
>     <serverVersion>opendap/3.7</serverVersion>
> </Opendap>
> The logs reads:
> 2010-08-25T17:05:30.130 +0800 [     82496][      18] INFO  - 
> thredds.server.opendap.OpendapServlet - Reject request size = 81.0 Mbytes
> I have tried it on a few datasets, reloading my webapp
> as well as restarting tomcat but to no avail.
> Could someone kindly assist?
> Thanks.
> Derrick Wong 
> Software Engineer | ASRDC (Australian Spatial Research Data Commons) Project 

thredds mailing list
For list information or to unsubscribe,  visit: