Re: netcdf 3.6.2 alpha 1 release now on netCDF FTP site...

"Sean McBride" <sean@xxxxxxxxxxxxxxxxxx> writes:

> On 2006-05-09 19:58, Ed Hartnett said:
>>The reason this is an alpha release is that we are testing out a new
>>build system, based on Automake and Libtool.
> I tried to build it on my Mac OS X 10.4.6 machine with Xcode 2.2 (gcc
> 4.0.1) and I'm having problems...
> First of all, in 3.6.1 there was a text file named 'INSTALL' that had
> install instructions, I don't see that file anymore, where are the
> compilation instructions?

Whoops! Thanks for noticing. I have fixed that for the next release.

Also I will get the latest documentation up on the website today.

> So I tried the usual ./configure; make and 'make' failed saying:
> "cfortran.h:138:3: error: #error "cfortran.h:  Can't find your
> environment among:"
> then listed a bunch of Fortran compilers it knows about.
> Further up, I see:
> "configure: finding Fortran compiler (required, even if Fortran API is
> not desired)"
> But I don't have a Fortran compiler, yet was able to build 3.6.1, do I
> need one now for 3.6.2?

No, you don't need a fortran compiler. I see that I phrased that
message badly. I meant that it is required for the configure script to
check for a fortran compiler, even if you don't want to use it. I have
modified that so the next release will be more clear.

Could you send me the output of your configure which has this problem?

Then try again (do a "make distclean" first), and set the FC
environment variable to nothing, or else provide the --disable-f77
option to configure.

This works for me in shell:

make distclean && FC= ./configure && make check\

Or else like this:

make distclean && ./configure --disable-f77 && make check


Ed Hartnett  -- ed@xxxxxxxxxxxxxxxx

To unsubscribe netcdfgroup, visit: