[gembud] GOES17 plotting via gpmap

Hi Gembuds,
I'm a longtime user of Gempak, and maybe 10 years ago I had a little better
grasp of how it all works.  Nonetheless, I'm trying to replace some of my
outdated satellite images scripts with newer GOES17 images from the NIMAGE
feed of GOES17 data.  So, not the original nc files, but the adjusted
version supplied by Unidata that theoretically can be plotted in Gempak.

My system is running the latest versions of LDM and Gempak at this level:
Linux vulcan.XXX 3.10.0-957.21.3.el7.x86_64 #1 SMP Tue Jun 18 16:35:19 UTC
2019 x86_64 x86_64 x86_64 GNU/Linux

I tried several times to get images to plot via gpmap with various standard
GAREA entries, but I kept getting this error:
" [GEMPLT -60]  NIMCORD - Invalid image display coordinates."

Then I tried various geographic identifiers.  With GAREA=US I got this to
plot for the CONUS image:
And then interestingly when I plot the Full Disk image and use GAREA=US, I
get this:

HMM....strange, somethings seems off with the lat lon registration.

Then I fiddled with adding lat lon corners and got some to work, but plots
are much farther east than expected:
GAREA = -165;15;-155;25
produces: http://www.met.sjsu.edu/weather/images/test/goes-vis3.gif
produces http://www.met.sjsu.edu/weather/images/test/goes-vis4.gif

So, clearly gempak is not reading something about the lat/lon correctly.
Before I go any further in my "pool sweep" level of troubleshooting, might
there be a $GEMTBL/sat/imgtyp.tbl adjustment needed here?  Or would anyone
have another tip to help diagnose my underlying issue.


Mike Voss
SJSU Meteorology
  • 2019 messages navigation, sorted by:
    1. Thread
    2. Subject
    3. Author
    4. Date
    5. ↑ Table Of Contents
  • Search the gembud archives: