[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[McIDAS #MXM-826197]: Problems remapping netCDF grid files



Hi Clair,

re:
> Thanks so much for investigating this and your explanation!

No worries.

re:
> I would not have figured it out.

Well, it took a lot of code diving to find the subtle bug I referred to.
After fixing that bug, I was able to walk my way through the code to the
crux section where it became glaringly apparent that the code that is
in place is far from generic when it comes to dealing with arbitrary
netCDF files.  This was a big disappointment for me.

re:
> I will try to replicate what you have done using McIDAS-V and/or IDV.

What I did was very simple:

- put one of your netCDF files in a directory where either/both McIDAS-V
  and the IDV could access it

  Some explanation: my environment is a Windows 7 laptop on which I run
  a CentOS x86_64 virtual machine in VMware Player.  My McIDAS development
  environment is the CentOS VM.  All I run in Windows are things like
  MS Office, and the IDV and McIDAS-V.

- run McIDAS-V and open:

  File -> New Display Window -> Globe Display -> One Panel

- add a Create Drawing Control widget to the gui from:

  User Preferences -> Toolbar Options

- put up the NASA Blue Marble by clicking on the newly added Create Drawing 
Control
  button

- read in one of your netCDF files from:

  Data Sources -> General -> Files/Directories

  After navigating to the file, I highlighted it and clicked on Add Source.

- brightness temperature for channel 2 at 10.8 um was then shown in
  the Fields window of the Field Selector

  I chose Color Shaded Plan View from the Displays -> Plan Views menu and
  then clicked on Create Display.

- from there, I changed the color table to light grayscale and inverted
  the mapping of display values in the Change Range widget you get when
  you right click on the color bar in the legend on the right side of
  the display

  I changed the default mapping of 184 to 304.5 to 304.5 to 184.

- I turned off the wireframe box from the Properties dialog under
  View

- I turned on the Lat,Lon lines from Layer Controls -> Default Background Maps
  and set the pattern to dots and the color to white

- I then captured the PNG image from View -> Capture -> Image

re:
> My boss is away at the moment, I imagine we might want you to explain the 
> problem
> with the netCDF files

OK, no worries.  The problem is in the McIDAS-X code, not in the netCDF files.

re:
> but, in case not, I don't want you to waste your time so can
> I get back to you on that?

Sure, no problem.

re:
> Thanks!

No worries.  I'm just sorry that what I ran into can't be fixed in any sort of
short time frame.

Cheers,

Tom
--
****************************************************************************
Unidata User Support                                    UCAR Unidata Program
(303) 497-8642                                                 P.O. Box 3000
address@hidden                                   Boulder, CO 80307
----------------------------------------------------------------------------
Unidata HomePage                       http://www.unidata.ucar.edu
****************************************************************************


Ticket Details
===================
Ticket ID: MXM-826197
Department: Support McIDAS
Priority: Normal
Status: Closed
===================
NOTE: All email exchanges with Unidata User Support are recorded in the Unidata 
inquiry tracking system and then made publicly available through the web.  If 
you do not want to have your interactions made available in this way, you must 
let us know in each email you send to us.



NOTE: All email exchanges with Unidata User Support are recorded in the Unidata inquiry tracking system and then made publicly available through the web. If you do not want to have your interactions made available in this way, you must let us know in each email you send to us.