Re: [visad] Linear*DSet progression arguments... bug or feature?

Hi Stefan-

Again, I think what you are seeing is a precision problem. For the first time series plot, I think when you use time that the time series is being condensed because the range of the times is 11 days from the look of the plot. You could probably set the range on the x axis to be a smaller range and see the whole line. Similarly for the vector plots.

Following on Curtis' suggestion, you could use a different unit than seconds since 1970-01-01 00:00:00. You could use:

Unit dateUnit = visad.data.units.Parser.parse("seconds since 2012-03-13 00:00:00);

(or whatever you want for a reference time) and then use that unit as the Set Units in the Linear*DSet constructor:

domain_set = new Linear2DSet(domain_tuple, 0.0, NROWS, NROWS,
0, NCOLS, NCOLS, (CoordinateSystem) null, new Unit[] {dateUnit}, (ErrorEstimate[]) null);

Don




On 3/13/12 7:04 AM, Stefan Below wrote:
Hi,
what i wanna do is plotting time series.

When i set the Linear*set or griddedset to fake dates (eg. from 0 to
numbers of steps)
time_set = new Linear1DSet(time, 0,5, 5);

the plot is ok. (http://tinypic.com/r/121ykxl/5)

But when i change the Linearset to real time values like

double currentTime = new DateTime().getValue();
time_set = new Linear1DSet(time, currentTime,currentTime+5, 5);


i get this plot: http://tinypic.com/r/161hw0n/5
(Axis labels are correct, but plot shows only one singe vertical line)


xAxis is mapped to RealType.Time

Thanks for your help,
Stefan

Am 13.03.2012 14:49, schrieb Don Murray:
Hi Stefan-

I'm not sure what you mean by "the plot looks very strange".
Linear*DSets are backed by float values, so when you use very large
numbers, you will run into precision problems. If you need that type
of precision, then you could use the Gridded*DDoubleSet.
Unfortunately, there are no Linear*DDoubleSet classes.

Don

On 3/12/12 9:26 AM, Stefan Below wrote:
Hello,

i am just start learning this powerful visualisation library and now
some questions come up.

When i use Linear*DSet with arithmetic progression, i get different
visualisation results when first/last arguments are quite high.

For example, if i use this
domain_set = new Linear2DSet(domain_tuple, 0.0, NROWS, NROWS,
0, NCOLS, NCOLS);

the plot looks fine.

But when i use
long xEnd=System.currentTimeMillis();
long xStart = xEnd-NCOLS;
domain_set = new Linear2DSet(domain_tuple, 0.0, NROWS, NROWS,
0, NCOLS, NCOLS);

(Look at the attachment for a full working example , line 112ff)

The plot looks very strange.
I expect that the plot is the same except the labels of the xAxis.

Maybe someone can give me a hint?

Or do i have to set the Axis values in an other way?

Thanks,
Stefan Below






_______________________________________________
visad mailing list
visad@xxxxxxxxxxxxxxxx
For list information, to unsubscribe, visit:
http://www.unidata.ucar.edu/mailing_lists/


_______________________________________________
visad mailing list
visad@xxxxxxxxxxxxxxxx
For list information, to unsubscribe, visit:
http://www.unidata.ucar.edu/mailing_lists/

--
Don Murray
NOAA/ESRL/PSD and CIRES
303-497-3596
http://www.esrl.noaa.gov/psd/people/don.murray/