RE: GraphicsModeControl.setPointSize with a DisplayImplJ3D under win2k

Thanks Don & Mathias --- I've upgraded to jdk 1.4.1, j3d 1.3 and actually the 
openGL & directX packages both solved the pointSize problem, but caused another 
(less serious from my point of view) problem.

I've got a two-monitor "Radeon 7000" series adapter running 16-bit color 
2560x1024 which (oddly enough) only works with Java3D when one monitor is 
disabled.  I say "oddly enough" because originally, when I was just having the 
pointSize problem, both monitors were enabled.  Now if I disable one and run in 
1280x1024 all's well.  Hate to press my luck by asking two questions on my 
first day on this list but I've tried everything I can think of.

Thanks,
Greg

-----Original Message-----
From: Mathias Stümpert [mailto:atzes@xxxxxx]
Sent: Tuesday, February 25, 2003 2:39 PM
To: dmurray@xxxxxxxxxxxxxxxx; Howell, Greg
Subject: AW: GraphicsModeControl.setPointSize with a DisplayImplJ3D
under win2k


Hi Greg, hi Don,

> > I'm running VisAD under linux, solaris, and now windows --- the only

> > problem I'm having is that calls to setPointSize seem to be ignored 
> under > windows.  e.g. in Test35.java the points look fine on the 2d 
> display but 
> > are apparently of size 1 on the 3d display.
> > 
> > Has anyone else come across this problem?
> 
> I suspect you are using the DirectX version of Java 3D.
> Point size didn't used to work under this.  I've also
> recently found that LineWidth has no effect under the
> DirectX version.

I realized this problem, too. But since I have changed to the newest
DirectX/JDK/Java3D-Versions the problem is gone. Point sizes and line
widths are working. I am using jdk 1.4.1, j3d 1.3 and DirectX 8.1

Hope that helps