Re: Java3D crashes Xserver

Hi Kevin,

I hit this particular problem myself last August when I got a
Radeon card.  The bug was in Mesa, and I submitted a patch to
the Mesa developers which was included in the 4.0 (22 Oct 2001)
release from  However, since XFree86 4.1.0 was
released on 2 June, it does not include the necessary patch.
Just installing Mesa 4.0 libraries is not sufficient to fix the
bug, since Mesa support is built in to the X server.

If you're willing to build an X distribution from the current
XFree86 development tree, it includes a newer Mesa with the
necessary fix.  For info on public CVS access, see:

Otherwise, it may be necessary to wait for the next release of

Hope this helps,

Chris Burghart

Kevin L. Manross wrote:

Hello all,

i know this has been mentioned offline and on this list, but i'm still not able to achieve success.

i'm running RH 7.1 with XFree86 4.0.3. Although the web sites say that it is unnecessary with this version of XFree86, i've gone ahead and installed Mesa-4.0 and i have "glx" and "dri" loaded in my XF86Config-4 . My Xserver still crashes every time i exit a Java3D application (demos and VisAD examples). There is little or no help from Blackdown's web site regarding this and the few times i've tried to contact them regarding it, i've never received any response.

i'm using an ATI Raedon video card which appears to be supported by Mesa3D.

So i'm asking the list if there is anyone who might be able to help me with this. i'd be very appreciative.

Thank you!


  • 2002 messages navigation, sorted by:
    1. Thread
    2. Subject
    3. Author
    4. Date
    5. ↑ Table Of Contents
  • Search the visad archives: