Re: getImage() problem under J3D

Hi Ugo,

> I've been having problems with DisplayImpl.getImage(). It returns me a
> black image when the display is 3D. I ran examples 50 and 51. The first
> returns an image from a
> 2D display without problems. The example 51 doesn't.
> 
> Then I ran the SpreadSheet and tried to creat a screenshot from a cell,
> but it returned the black image (as expected :-(
> 
> Has anyone been having this problem?
> 
> I'm using Java 1.3 (just released!) under Solaris 2.6. Java3D is 1.1 (or
> the like; but definitely not the latest, as it is buggy).
> Anyone with an idea of what's happening?

Test51 and saving a JPEG from the SpreadSheet both work for me
and I'm running pretty much the same software:

  doll% java -version
  java version "1.3.0"
  Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.0-beta_refresh)
  Java HotSpot(TM) Client VM (build 1.3.0-beta_refresh, mixed mode)

  doll% uname -a
  SunOS doll 5.6 Generic_105181-14 sun4u sparc SUNW,Ultra-5_10

and Java3D version 1.1.2.  If you are running 1.1.3, that has
some bugs (high hopes for the 1.2.1 beta due soon).

If you want to dig, the critical logic is in
visad/java3d.VisADCanvasJ3D in the postSwap() method.
It sees the captureFlag == true then gets
'BufferedImage captureImage' using the usual Java3D logic.

I want to help fix this, but since I can't duplicate the
error will need your help.  You might try changing Java3D
versions.  Note Java3D version 1.1.2 for Solaris is still
available at:

  ftp://www.ssec.wisc.edu/pub/visad-2.0/java3d1_1_2-sol-sdk.bin

Cheers,
Bill
----------------------------------------------------------
Bill Hibbard, SSEC, 1225 W. Dayton St., Madison, WI  53706
hibbard@xxxxxxxxxxxxxxxxx  608-263-4427  fax: 608-263-6738
http://www.ssec.wisc.edu/~billh/vis.html