Re: Java heap space

Do this from a terminal:

ps -ef | grep tomcat

You should be able to find the ps that is running THREDDS. Could you copy the entire response and email it. It will show the Java settings that were set when you launched the application.


-Roy M.
On May 8, 2007, at 8:37 PM, Pauline Mak wrote:

Hi Ethan,

I've tried to use my test server again today, and have found that it's
getting a Java heap space problem.  I then restarted my server and it
can load the large dataset. However, if I refreshed the page, I get the
Java heap space problem.

Ahh, I tried that restart/reload a few more times, and it seems like it works for the first few loads, and then any large dataset will result in
the error.

Having said that, if I went back through the smaller dataset, TDS will
show smaller dataset fine.

This is what I get in catalina.out:

2007-05-09T12:17:27.275 +1000 [   3495267][      97] ERROR -
thredds.servlet.CatalogServicesServlet - doGet req catalog= catalog.xml got Exception
java.lang.OutOfMemoryError: Java heap space
2007-05-09T12:17:27.294 +1000 [   3495286][      97] ERROR -
thredds.servlet.ServletUtil - handleException
java.lang.OutOfMemoryError: Java heap space
java.lang.OutOfMemoryError: Java heap space

I tried to setup the remote management thing in tomcat without success, so I'm afraid I can't give you more details until I can get that up and



On Mon, 2007-05-07 at 09:23 -0600, Ethan Davis wrote:
Hi Pauline,

Did the cache permissions solve the problem you were having with
scanning directories that contain large numbers of files? Was the
scanning to generate a catalog or was it an aggregation?


Pauline Mak wrote:
HI Ethan,

Yes, I've noticed that occasionally it will show an OurOfMemory error.

I'm currently running is

THREDDS Data Server Version 3.14.02 Build Date = 2007-03-19 23:50:44
JVM is java version "1.5.0_09"
Tomcat is: 5.5

Wow, the oddest thing just happened. I noticed that catalina.out were printing out messages saying that tomcat had problems trying to access cache.log. So I went in and change the ownership of all cache* and then
THREDDS was able to load those big datasets without problems.  Oops,
sorry!  I should read the log more carefully!



====================================================================== ========
To unsubscribe thredds, visit:
====================================================================== ========

"The contents of this message do not reflect any position of the U.S. Government or NOAA."
Roy Mendelssohn
Supervisory Operations Research Analyst
Environmental Research Division 
Southwest Fisheries Science Center
1352 Lighthouse Avenue
Pacific Grove, CA 93950-2097

e-mail: Roy.Mendelssohn@xxxxxxxx (Note new e-mail address)
voice: (831)-648-9029
fax: (831)-648-8440

"Old age and treachery will overcome youth and skill."

To unsubscribe thredds, visit:

  • 2007 messages navigation, sorted by:
    1. Thread
    2. Subject
    3. Author
    4. Date
    5. ↑ Table Of Contents
  • Search the thredds archives: