Re: support for IDV 1.2 on MacOS X 10.4

I have a related problem, when I try to run the IDV
1.3A2 app for Mac OS X, I get the following error:
"Could not launch the application because it requires
a version of Java that is not installed. 
This application requires Java 1.4, but only 1.4.2 and
1.3.1 are installed. Updating to a newer version of
Mac OS X may resolve this issue."

I am running Mac OS X 10.3.9, obviously with Java
1.4.2. I can run the older version of IDV (1.2). I
also can run the IDV 1.3A2 using the "runIDV"
executable that came with the package.

--Alan Klein


--- "Mark J. Laufersweiler"
<laufers@xxxxxxxxxxxxxxxxxx> wrote:

> 
> I am running the IDV on my Mac (10.4.2) BUT with
> java 1.4. I checked
> with the developers when the Apple update to 1.5
> came out. They
> confirmed and it is listed on the link that Tom sent
> you IDV does
> not work with 1.5.
> 
> Not sure how hard it will be, but you will need to
> back out of java
> 1.5  to 1.4.whatever.
> 
> mjl
> 
> 
> On Fri, 7 Oct 2005, John C Cartwright wrote:
> 
> > Thanks for your prompt reply, Tom.  I did see that
> note, and it would
> > seem from Apple that Java3D is not available on
> 10.4.
> >
> > However, I had heard elsewhere that Java3D was
> "built-in" to 10.4 -
> > hence my confusion.
> >
> > I did install IDV 1.2 on my Mac, but it throws all
> kinds of exceptions
> > and I hoping someone else might have previously
> travelled this road.
> >
> > Did I understand correctly that your cube-mate's
> mac seemed to work OK
> > w/ 1.2 and 10.4?
> >
> > Thanks again!
> >
> > -- john
> >
> >
> > Tom Whittaker wrote:
> > > Hi John:
> > >
> > > If you check out this page:
> > >
>
<http://www.unidata.ucar.edu/software/idv/docs/userguide/Systems.html>
> > >
> > > you will see that you need to install Java3D
> (section 1.1.0, at the ****
> > > note).  There is also a link to get it.  My only
> experience with IDV on
> > > Macs, however, has been limited to alittle
> testing on my cube-mates Mac,
> > > and I've only used the WebStart version.
> > >
> > > tom
> > >
> > > John C Cartwright wrote:
> > >
> > >> Hello,
> > >>
> > >> I'm a little confused about support on MacOS
> 10.4. I have java 1.5
> > >> installed, but it's unclear to me whether
> Java3D is built into it or
> > >> available separately. IDV 1.2 doesn't seem to
> work as is.
> > >>
> > >> Can someone clarify for me?
> > >>
> > >> Thanks!
> > >>
> > >> -- john
> > >
> > >
> >
> >
> 
> -- 
>
--------------------------------------------------------------------
>   Dr. Mark J. Laufersweiler     |
>   School of Meteorology         |     Those who give
> up essential
>   University of Oklahoma        |   liberties for
> temporary safety
>   laufers@xxxxxx                | deserve neither
> liberty nor safety.
>   (405) 325-6032                |             -
> Benjamin Franklin
>   (405) 325-7689  (fax)         |
> 
>