[gembud] DCGRIB2 failing on new NAM CONUS-nest files

  • To: gembud@xxxxxxxxxxxxxxxx
  • Subject: [gembud] DCGRIB2 failing on new NAM CONUS-nest files
  • From: Russ Schumacher <russ.schumacher@xxxxxxxxxxxxx>
  • Date: Wed, 22 Mar 2017 10:46:29 -0600
  • Authentication-results: unidata.ucar.edu; dkim=none (message not signed) header.d=none;unidata.ucar.edu; dmarc=none action=none header.from=colostate.edu;
  • Spamdiagnosticmetadata: NSPM
  • Spamdiagnosticoutput: 1:99
Hello gembuds, 

Since the recent NAM upgrade, my call to DCGRIB2 to decode some of the fields 
into GEMPAK format files has been failing.

In particular, hereâs an example command and the error message:

dcgrib2 -m 10000 -v 1 -d logs/dcgrib2_namnest.log -e GEMTBL=$GEMTBL -e 
MDMETH=MDGDEC YYYYMMDDHHfFFF_nam4km.gem < nam.t00z.conusnest.hiresf60.tm00.grib2
 Opening WMO Originating Center Table wmocenter.tbl...
 Opening WMO GRIB2 Parameter Table g2varswmo2.tbl...
 Opening WMO GRIB2 Vertical Coordinate Table g2vcrdwmo2.tbl...
Abort trap: 6

So, not a very instructive error message, unfortunately.

The GRIB2 files can be found at (for example): 
http://nomads.ncep.noaa.gov/pub/data/nccf/com/nam/prod/nam.20170322/nam.t00z.conusnest.hiresf60.tm00.grib2
 
<http://nomads.ncep.noaa.gov/pub/data/nccf/com/nam/prod/nam.20170322/nam.t00z.conusnest.hiresf60.tm00.grib2>
  (although Iâm only pulling a subset of fieldsâbut I also tested a full file 
and got the same result)

Iâm using GEMPAK 7.3.1 on a Mac OS X.  This command always worked prior to the 
NAM upgrade, and NAGRIB2 works just fine on these new files, so I suspect 
thereâs just something in the decoder tables, etc., for DCGRIB2 that need to be 
updated.  Any ideas/solutions would be welcome â thanks!

Russ



--
Russ S. Schumacher
Associate Professor
Department of Atmospheric Science
Colorado State University
e-mail: russ.schumacher@xxxxxxxxxxxxx
phone: 970.491.8084
web: http://www.atmos.colostate.edu/faculty/schumacher.php