problem adding grids in gdedit

Dear gembud,

I recently tried to add a grid to an existing GEMPAK file using gdedit, but I 
receive the following error:
blinky:/projects/proto/WRF/EMS/wrf/runs/CONUS/wrfpost/gempak > gdedit
GDEFIL    Grid edit file                   gdedit_cbas.fil
GDFILE    Grid file                         200608172100_nmm_pres12km.grd
GPACK Packing type/number of bits Parameters requested: GDEFIL,GDFILE,GPACK.
GEMPAK-GDEDIT>r
[GDEDIT -6]  Error reading grid data.
Parameters requested: GDEFIL,GDFILE,GPACK.
GEMPAK-GDEDIT>e

A little background:
Using the existing GEMPAK file listed above, I ran gdlist to create an output 
of an entire grid (601x371).
This grid contains negative values that I want to set to missing (-9999.00), so I substituted the negative values using shell commands, preserving the row and column orientation, and wrote the data to a file called "gdedit_cbas.fil". When I tried to add the new grid to the same GEMPAK grid file, I got the error above. I have ensured that the file has the same # of entries and rows as the actual grid file.

FYI, the header of "gdedit_cbas.fil" is as follows:

Grid file: 200608172100_nmm_pres12km.grd GRID IDENTIFIER: TIME1 TIME2 LEVL1 LEVL2 VCORD PARM 060817/2100F012 0 NONE CBAS AREA: DSET GRID SIZE: 601 371
COLUMNS:     1  601     ROWS:     1  371
Scale factor: 10** 0

COLUMN:      1        2        3        4        5        6        7        8
(etc, etc, etc)

Your feedback & assistance is greatly appreciated!
Regards,
Jonathan Case