RE: FW: Problem with DumpType


     In regard to my problems building VisAD with Nmake:

     It worked with CLASSPATH=C:\Java\VisAD, which is the parent of the
visad directory for me.  (My Java\VisAD is your src.)  

     I was previously using CLASSPATH = ..;., then
CLASSPATH=C:\Java\VisAD;C:\Java\VisAD\visad.  (See below near the end.)  The
reason is that the readme ( says to
use both:

Your CLASSPATH sould include:

  1. The parent directory of your visad directory.
  2. The current directory.

     Looks like the makefile is fine but readme should be changed.

     Thanks for your help.  It certainly saved my working on it until I
figured that out.  I would really like to get it to build in Eclipse, but
being able to build at least somewhere is good.  Unfortunately (or
fortunately ;-) I will be going on vacation and can't spend the time just


-----Original Message-----
From: tomw.ssec@xxxxxxxxx [mailto:tomw.ssec@xxxxxxxxx] On Behalf Of Tom
Sent: Tuesday, June 27, 2006 7:24 PM
To: Kenneth Evans, Jr.
Subject: Re: FW: Problem with DumpType

Hi Ken:

It looks like a CLASSPATH problem (at least to begin with).  The
CLASSPATH must be set to the parent directory.  For example, if your
VisAD source code is in:  c:\src\visad\
then CLASSPATH should be set to "c:\src".  I usually use this:  "c:\src;.\"

Please give that a try....and let me know....



On 6/27/06, Kenneth Evans, Jr. <evans@xxxxxxxxxxx> wrote:
> Tom,
>      I hadn't tried to rebuild it since I first downloaded it in April.  I
> tried again after getting your message and this is what I got:
> ...
> Note: rabin\ uses or overrides a deprecated API.
> Note: Recompile with -deprecation for details.
>         javac -J-mx64m -g aune\*.java
>         javac -J-mx64m -g bom\*.java
>         javac -J-mx64m -g aeri\*.java
>         javac -J-mx64m -g data\amanda\*.java
>         javac -J-mx64m -g georef\*.java
>         javac -J-mx64m -g meteorology\*.java
> Note: meteorology\ uses or overrides a deprecated API.
> Note: Recompile with -deprecation for details.
>         javac -J-mx64m -g install\*.java
>         cd examples
>         javac -J-mx64m -g *.java
> package visad does not exist
> import visad.*;
> ^
> package visad.java2d does not exist
> import visad.java2d.DisplayImplJ2D;
>                     ^
> cannot access VisADException
> bad class file: ..\VisADException.class
> class file contains wrong class: visad.VisADException
> Please remove or make sure it appears in the correct subdirectory of the
> classpath.
>     throws VisADException, RemoteException
>            ^
> 3 errors
> NMAKE : fatal error U1077: 'c:\j2sdk1.4.2_06\bin\javac.EXE' : return code
> '0x1'
> Stop.
> NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio
> 8\VC\BIN\nmake.EXE"' : return code '0x2'
> Stop.
> C:\Java\VisAD\visad>
> ------------------------------------------------------------------------
> I ran it from a .bat file with:
> set CLASSPATH=..;.
> set JAVA_HOME=c:\j2sdk1.4.2_06
> set PATH=%JAVA_HOME%\bin;%PATH%
> nmake -f Makefile.WinNT debug
>      It doesn't seem to like CLASSPATH=..;.  I changed it to
> CLASSPATH=C:\Java\VisAD;C:\Java\VisAD\visad, and that got rid of the error
> at line 32, but it still got the next one at line 40.  The thing that is
> different about examples is the cd.
>         -Ken

Tom Whittaker
University of Wisconsin-Madison
1225 W. Dayton Street
Madison, WI  53706  USA
ph: 608-262-2759

To unsubscribe visad, visit:

  • 2006 messages navigation, sorted by:
    1. Thread
    2. Subject
    3. Author
    4. Date
    5. ↑ Table Of Contents
  • Search the visad archives: