Re: though I can definitely see the classes under javax/media/j3d

  • To: Victor Shum <vshum12@xxxxxxxxxxx>
  • Subject: Re: though I can definitely see the classes under javax/media/j3d
  • From: Tom Whittaker <tomw@xxxxxxxxxxxxx>
  • Date: Thu, 30 Dec 2004 20:46:28 -0600

I cannot vouch for JDK5.0 -- I only use 1.4.2. There may be issues with JDK5 with JAR files built using non-JDK5.0 Java versions. The visad release is compiled with 1.4.1.

Please refer to this page:
regarding Java3D for Linux.

On Windows, cygwin is not used (unless you need to compile C or Fortran, I suppose). There are source files in the VisAD source in native code, but they are not required (and in fact are not really part of the visad library) unless you need their functionality...I don't even have C or Fortran compilers on my machine any more.

There is probably no reason to extract the contents of the visad.jar file -- just put it in your CLASSPATH; nor do I believe you should have to recompile VisAD...but it does depend on what you are trying to do, I suppose. If you need to modify VisAD core modules, you can create a separate tree and just put your updated modules there and include the parent of the tree in your CLASSPATH as well.

I will leave it to others who might use netbeans, since i do not.


Victor Shum wrote:
Thanks Bill, I reloaded the jdk5.0 For the J3D, I only saw the one for solaris :;jsessionid=ABCA2C33193C3481421A7F181261A4E1;jsessionid=ABCA2C33193C3481421A7F181261A4E1

I saw another website with xj3d for debian linux:

Dunno if that works since I had so much trouble on J3D
I can switch to running visad on windows, my question
is, for windows, which cygwin will definitely work
with visad or netbean itself is sufficient?
I had some trouble to get netbean to compile visad.


--- Bill Hibbard <billh@xxxxxxxxxxxxx> wrote:

Victor, at this point I cannot imagine what is going
wrong. There is no seperate "visad distribution for
redhat linux 9.0" or any other OS. I suggest
over, and following the instructions for "Installing
VisAD from Java source code" at:


Good luck,

On Thu, 30 Dec 2004, Victor Shum wrote:

Thanks Bill!

I did that and still I got those errors.

I'm gonna redownload the correct visad


for redhat linux 9.0 which I'm running on, both


compiled visad-in-a-box one and the source code


By any chance you know the link of those?

The visad in a box one I downloaded and installed
before looked like a solaris version so that may


why I got the error on the Test#s when I ran java

--- Bill Hibbard <billh@xxxxxxxxxxxxx> wrote:

On Thu, 30 Dec 2004, Victor Shum wrote:

. . .
3. /usr/local/src/visad under which I have my


visad files and also under which I ran the


compile for compilation.

If,, etc are in your
/usr/local/src/visad directory and that's where


ran 'make compile', then your CLASSPATH should

Try that and let us know if you continue to have

Good luck,

  • 2004 messages navigation, sorted by:
    1. Thread
    2. Subject
    3. Author
    4. Date
    5. ↑ Table Of Contents
  • Search the visad archives: