Re: Problem 'make'ing VisAD due to HD5 libraries

On my Windows2K box, I compiled with jdk 1.4.1_01 (with Java3D 1.3 I think) without difficulty. I run 'nmake -f makefile.winnt compile' from within the "c:\src\visad\" directory. I monitored the "c:\src\ncsa\hdf\hdf5lib\" directory in another window, and noted that the H5.class file was created during the very first javac: "javac -J-mx64m *.java" (way at the end of it, though).

My classpath is set to "CLASSPATH=c:\src;.\" which might make a difference somehow.

Hope some of that helps.

tom

tsc wrote:
I'm using j2sdk 1.4.1 on both platforms

--- Bill Hibbard <billh@xxxxxxxxxxxxx> wrote:

Hi Tim,


I'm having a problem building visad from source, i've tried in both linux and 
in windows 2000, and both result in similar errors:

C:\java\visad>nmake -f Makefile.winnt compile
C:\java\visad\util\Util.java:376: cannot resolve symbol
symbol  : variable H5
location: class visad.util.Util
     H5.J2C(0); // HDF-5 call initializes HDF-5 native library
     ^
2 errors
NMAKE : fatal error U1077: 'C:\WINNT\system32\cmd.exe' : return code '0x1'
Stop.

The error under linux is similar, except that make continues on, trying the 
other files (and giving more errors about HDF-5 type things)
Does anyone have a suggestion for how to resolve this?

We have never seen this error before.

H5 is in the ncsa.hdf.hdf5lib package distributed with VisAD. The only
thing I can think of is that visad.util occurs before ncsa.hdf.hdf5lib
in the list of packages in the VisAD Makefile, and that you are using a
Java compiler that will not automaticaly try to compile imported
classes that are not already compiled. What compiler are you using?

Cheers,
Bill


_____________________________________________________________
<a href="http://www.gamedev.net";>GameDev.net Email Service</a> - "Plenty of 1's and 
0's"

_____________________________________________________________
Select your own custom email address for FREE! Get you@xxxxxxxxxxxxxx w/No Ads, 
6MB, POP & more! http://www.everyone.net/selectmail?campaign=tag



--
Tom Whittaker (tomw@xxxxxxxxxxxxx)
University of Wisconsin-Madison
Space Science and Engineering Center
Cooperative Institute for Meteorological Satellite Studies
Phone/VoiceMail: 608.262.2759