Re: problem with DisplayImpl..

Hi Isaac,

NoClassDefFoundError really looks like a CLASSPATH problem.
Are you certain it's set properly?  Where did you extract
visad_src-2.0.jar, and what is the value of your CLASSPATH?

-Curtis

At 12:41 PM 7/16/2002, you wrote:
> I compiled visad from the command line by doing
>C:\visad>javac *.java which compiled fine because the Nmake thing gives 100
>errors when i tried it.
>Later when i tried to run my applet by doing
>C:\brobbs>appletViewer Vasxe.html
>i get the following error
>java.lang.NoClassDefFoundError: visad/DisplayImpl
>        at java.lang.Class.newInstance0(Native Method)
>        at java.lang.Class.newInstance(Class.java:237)
>        at sun.applet.AppletPanel.createApplet(AppletPanel.java:586)
>        at sun.applet.AppletPanel.runLoader(AppletPanel.java:515)
>        at sun.applet.AppletPanel.run(AppletPanel.java:293)
>        at java.lang.Thread.run(Thread.java:484)
>
>then i tried to manually compile javac DisplayImpl.java
>
>it gives the following error again
>
>C:\visad>javac DisplayImpl.java
>
>DisplayImpl.java:58: removeAllSlaves() in visad.DisplayImpl cannot implement
>rem
>oveAllSlaves() in visad.Display; attempting to assign weaker access
>privileges;
>was public
>public abstract class DisplayImpl extends ActionImpl implements LocalDisplay
>{
>                ^
>1 error
>
>
>is there any work around for this error ?
>
>thanks,
>
>Isaac