Re: Problem using RMI

"Vimal Gopal" wrote:
> Hello everyone,
> 
>     I am having a problem using VisAD's RMI capabilities.  I have
> rmiregistry running on one console and my server on another console.
> When I run a remote display on the same machine, everything works fine.
> However, when I run the same remote display on another machine I get an
> error.  Here is the error I am getting:
> 
> "Local Class not compatible: stream classdesc serialVersionUID:
> 2834199820960650 local classVersionUID=3D-8112387467706298840."
> 
> I have no idea what this means.

'rmic' assigns a serial number to the class file when it compiles it.
When an RMI connection is made, the serial numbers for the local and
remote classes are compared.  If they're different (because the two
class files are slightly different) RMI prints an error message like
the one above.

I'd guess that if you copy all the class files from the first
machine to the second one, this problem will disappear.

> Remember, the program works fine when running from same machine.

This happens because you're definitely using the same versions of
class files.