Re: Start with VisAD ....


"From: Bill Hibbard " wrote:

> Hi David,
>
> I am sorry for all the problems you are having.  Something very strange
> is going on here.
>
> > VerySimple.java compiles ok, but when I run it, it gives me the
> > following exceptions:
> >
> > Couldn't decode attribute y:units="promiscuous": Unit not in database
> > Couldn't decode attribute x:units="promiscuous": Unit not in database
> > Exception in thread "main" java.lang.NullPointerException
> >         at visad.util.DataUtility.makeSimpleDisplay(Compiled Code)
> >         at VerySimple.main(VerySimple.java:24)
>
> If you run under jdb, so the Exception will give line numbers,
> that will make it easier.  One possibility is that the file read
> failed, and SatDisplay passed a null Data object to
> DataUtility.makeSimpleDisplay.  SatDisplay reads its data directly
> from an ftp server, and might have timed out.
>
> > visad.ss.SpreadSheet.java program also compiles ok, and I loaded
> > images.nc dataset into this program, a 4-step 2D image appears in
> > one of four windows. But on the command, it shows the following
> > strange information:
> >
> > A nonfatal internal JIT <3.00.078<x>> error "regvar" has occured in :
> >    'visad/data/DefaultFamily$FormFunction.run <>Z': Interpreting method.
> >    Please report this error in detail to
> http://java.sun.com/cgi-bin/bugreport.cgi
>
> This is real spooky - an internal error in Java with an invitation
> to tell Sun.  I haven't seen an error like this for over a year.
>
> > We installed Java3D into window NT, and tried to run the two examples
> > relating to Java3D.
> >
> > HSVDisplay.java compiles ok, but the following exceptions occured when
> > I run it:
> >
> > Exception in thread "main" java.lang.NoCLassDefFoundError:
> > javax/media/j3d/GeometryArray
> >         at HSVDisplay(HSVDisplay.java:105)
>
> This indicates that Java3D may be improperly installed, since Java
> cannot find a Java3D class.
>
> > SatDisplay.java program can not pass compilatio with the following
> errors.
> >
> > SatDisplay.java:96: Method disableAction() not found in class
> visad.DisplayImpl.
> >
> >         display.disableAction();
> >                              ^
> >
> > SatDisplay.java:99: Method enableAction() not found in class
> visad.Display.Impl.
> >         display.enableAction();
> >                             ^
>
> This is spooky again.  DisplayImpl extends ActionImpl which does
> define the disableAction and enableAction methods.  Possibly you
> have more than one copy of the VisAD classes in your CLASSPATH,
> one old and one new (say, a visad.jar file, and class files
> compiled from source).  The disableAction and enableAction methods
> were added to ActionImpl within the last few weeks, so if you
> got copies from our ftp server at different times, you could have
> one version with these methods and one without them.
>
> Given how spooky all this is, you might delete Java 2, Java3D and
> VisAD, and reinstall everything very methodically.  I don't know
> much about NT, but VisAD does run properly on NT.  If reinstalling
> doesn't solve it, you might consider giving us access to your
> account, so one of our NT experts can log on remotely and check
> things out.
>
> Cheers,
> Bill
> ----------------------------------------------------------
> Bill Hibbard, SSEC, 1225 W. Dayton St., Madison, WI  53706
> hibbard@xxxxxxxxxxxxxxxxx  608-263-4427  fax: 608-263-6738
> http://www.ssec.wisc.edu/~billh/vis.html