Re: VisAD on Linux

Dear Bill,

"From: Bill Hibbard " wrote:

> Hi Guillaume,
>
> First, congtrats on your experiments with Java 2 and Java3D on Linux.
> I tried a few months ago with Blackdown's first release, but ran into
> UnsatisfiedLinkErrors when I tried to run anything that opened a window.
> So I have not yet run VisAD successfully on Linux.
>
> According to the VisAD FAQ, 'Class ... not found' errors are generally
> due to an error in your CLASSPATH.  However, since your errors are not
> occuring until you get to the visad/examples directory, where the source
> files do not include package statements, the problem may be more subtle.
>
> First, does your CLASSPATH include the parent directory of your visad
> directory, and '.' (the current directory)?  I believe that the '.' is
> necessary to compile visad/examples because these classes do not have
> a package statement.  As a test, you might try:
>
>   cd visad/examples
>   javac -J-mx32m *.java
>

This wors OK. I have been able to run Test40 to Test60. The only one which
is
failing is Test56 which starts with a : Connection refused to host :
localhost.
Have you seen this before ?
My problems were due to the fact that I was forgetting to diasable the JIT
compiler
which in not working in the current Blackdown version.

>
> Also, on all matters related to the VisAD Makefile I defer to Dave
> Glowacki, who knows much more about it than I do.  So Dave, please
> correct me if I'm wrong about this.
>
> > Then I have got the visad.jar file (to get rid of the compilation
> > problems) but I get another problem :the frame is disappearing
> > immediatly after the program is loaded (I can hardly see it).
> > Have you already met this ? Any idea ?
>
> This could be a problem with Linux Java 2 or Java3D.  Have you
> tried the demos under jdk1.2/demo/jfc or jdk1.2/demo/java3d?
>
> Do you get the disappearing frame with both Java2D and Java3D
> demos?  (Test41 for Java2D, Test42 for Java3D, in examples).
>
> Cheers,
> Bill
> ----------------------------------------------------------
> Bill Hibbard, SSEC, 1225 W. Dayton St., Madison, WI  53706
> hibbard@xxxxxxxxxxxxxxxxx  608-263-4427  fax: 608-263-6738
> http://www.ssec.wisc.edu/~billh/vis.html

What I would like now is to visualize 3D data coming from 3D surfacis
unstructured meshes. Is this possible ? Have you a test doing something
similar ? This could be a
good starting point.

Cheers

Guillaume