Re: [thredds] Problems with nc4 datasets on Ubuntu 8.04?

Sorry about my last error-report, it had nothing to do with thredds or Ubuntu. After carefully reading the logs again this morning, I found the problem to be with one of our own IOSP.

The IOSPs isValidFile should return false (not a XML-file), but threw an uncaught (Runtime?) Exception instead. After disabling that IOSP, I can serve again netcdf-4 files.

Best regards,


On 2012-03-12 17:58, Heiko Klein wrote:

I just tried to put netcdf4 files on an older thredds server (4.2.9)
running with Ubuntu 8.04, tomcat 6.0.33 and java 1.6.0_24 (tried with
openjdk 6.0.18, too).

Putting a netcdf4 file on the server, I get the error-message in thredds

Unexpected error of type
Invalid byte 1 of 1-byte UTF-8 sequence.

Converting the file to netcdf3, and using the nc3 file on that machine
works fine.

Putting the netcdf4 file on another machine, e.g. Ubuntu 10.04 works
fine, too.

Is there a known problem with older java software? Did somebody else see
this 'Invalid byte 1 of 1-byte UTF-8 sequence' before?

Best regards,


  • 2012 messages navigation, sorted by:
    1. Thread
    2. Subject
    3. Author
    4. Date
    5. ↑ Table Of Contents
  • Search the thredds archives: