[THREDDS #YVC-182954]: thredds aggregation

Hi Carl,

> I tried it and I think progress is being made.  I just get a simple
> error message now that it "can't find nwAtlanticDec_1km".  For some
> reason  the virtual dataset is not being recognized for access.  Does
> this imply that the aggregation is not taking place so no virtual file
> is being created?  I changed the service element base  in the script
> below to reflect the change I made.  I also tried it with just
> "/thredds/dodsC/" and got the same result.  Is there anything you see in
> the code that is preventing the aggregation?  If these are hdf4 files,
> would that cause a problem?  As you can see, the netcdf location I am
> using for the granule data uses our hyrax opendap server.

That does sound like something of an improvement.

Take a look at the catalogError.log file in content/thredds/logs directory? 
First off, is this config catalog getting initialized (i.e., is it listed in 
the log file)? If not, make sure it is in the catalog tree under the main 
catalog (content/thredds/catalog.xml) or is included in the threddsConfig.xml 
in a catalogRoot element.

If it is being initialized, are there any error messages in the log file?

It doesn't look like you have remote management setup on this machine (I just 
tried to get to http://satdat1.gso.uri.edu/thredds/debug and it timed out). If 
you did you could check the "Show static catalogs" link to see if the server is 
finding this config catalog. Also, the "Show ncml datasets" link will list all 
aggregation datasets. (We highly recommend setting up remote management. It 
really helps with debugging. Also, the "remote" part can be locked down pretty 

Hope this helps,


Ticket Details
Ticket ID: YVC-182954
Department: Support THREDDS
Priority: Normal
Status: Open

  • 2007 messages navigation, sorted by:
    1. Thread
    2. Subject
    3. Author
    4. Date
    5. ↑ Table Of Contents
  • Search the thredds archives: