Re: [netcdfgroup] NetCDF on OS X

I just installed netcdf on my apple (leopard) last night. I used the "snapshot" version here (link).
On Nov 6, 2007, at 9:38 AM, Ian Harris wrote:


I've resubbed after a long absence, because I'm trying to get the
NetCDF libraries (including those for F77 and F90) installed on a Mac
(2xG5 PowerPc Processors, OS 10.4.10).

The problem is that, when I try the first f77 test program
('simple_xy_wr.f'), the compilation fails with the familiar
underscore-laden symbol errors.

I've tried downloading the binaries, and compiling from source. I've
tried all combinations of gfortran and g77 for both NetCDF install
and test compile. I've played with the g95 -no_second_underscore (and
other!) options. I've spent two days on it so far and I'm going
quietly mad..

Has anyone managed to get the NetCDF libraries (pref. 3.6.2 but by
now I'll settle for anything) working on OS X? Is there a foolproof
guide anywhere?

I've looked at the thread earlier this year but it doesn't seem to
help, sorry.

System, etc details:

Mac OS X 10.4.10
Dual 2 GHz PowerPC G5
g77  - not currently installed (has been tried)
gfortran version GCC 4.0.2


Ian "Harry" Harris
Climatic Research Unit
School of Environmental Sciences
University of East Anglia
Norwich NR4 7TJ
United Kingdom

netcdfgroup mailing list
For list information or to unsubscribe,  visit: