Re: newtCDF-Java 2.2.10

Hi Robert:

Yes, its true we are using some 1.4 stuff like the URI class. Im not sure what else, its 
been a long time since I've run 1.3. It may be that the "minimal" netcdf 
library will work ok on 1.3 though. It would need to be recompiled under 1.3. If you want 
to try that, download the soruce distribution, and just compile ucar.ma2 and ucar.nc2. I 
_think_ it will work.

Generally 1.4 is better, faster, and less buggy than 1.3, im surprised that 
iText has problems. Is there anyone developing that still?

Sorry for not documenting this, I will update the web page.

Robert B. Schmunk wrote:


Is it the case that using the netCDF-Java library version 2.2.x  _requires_
the user have Java 1.4 installed?

I decided to take a look at upgrading Panoply from using nj-2.1.9 to the
current stable nj-2.2.10. After 15-20 minutes of mucking about figuring out
the changes in the API which specifically affected Panoply, I got the  app
back up and running... but only when I instructed it to use Java 1.4.  When
I limit it to using Java 1.3, I get the following error:

gov.nasa.giss.panoply.Panoply.main(String[]) threw an exception:
java.lang.UnsupportedClassVersionError: ucar/nc2/dataset/ NetcdfDataset (Unsupported major.minor version 48.0)

There is nothing on netCDF-Java homepage to indicate the particular  level
of Java required, so if 2.2.x requires a particular Java you may want to
update the website to explicitly say so.

This is probably not a big problem. I'd prefer to bump Panoply up to  Java
1.4 anyway, but I have also run into a problem with another 3rd party
libary (the iText PDF writer) which crashes under Java 1.4 when run  on Mac
OS X. (If it's not one thingsit's another...) Also, Panoply is used in a
number of classroom situations and one just never knows how up-to- date their
machines are being kept.


Robert B. Schmunk, rschmunk@xxxxxxxxxxxxx
NASA Goddard Institute for Space Studies, 2880 Broadway, New York, NY 10025