[netcdf-hdf] Problem with hdf5-1.8.X on i686 Linux machine?

Hi,

I would like to compile netcdf4.1.X with an intel compiler.
Hence, I installed /opt/intel-12.1.2/composer_xe_2011_sp1.8.273 for C, C++ and Fortran libraries.

Also, I reinstalled zlib and szip with this intel compiler.
I used the same flags as in the following post (https://www.unidata.ucar.edu/mailing_lists/archives/netcdfgroup/2011/msg00422.html):

export F77=ifort
export FC=ifort
export FCFLAGS='-O3 -ip'
export FFLAGS='-O3 -ip'
export CC=icc
export CFLAGS='-O3 -ip'
export CXX=icpc
export CXXFLAGS='-O3 -ip'

Now, in configure hdf5-1.8.7 as follows:
./configure --with-zlib=/usr/local/zlib-1.2.6_intel_12.1.2 --with-szlib=/usr/local/szip-2.1_intel_12.1.2 --prefix=/usr/local/hdf5-1.8.7_intel_12.1.2 --enable-fortran --enable-cxx

that works fine.
With "make", all goes well.

But when doing "sudo make install" I get the following error:
test -z "/usr/local/hdf5-1.8.7_intel_12.1.2/bin" || /bin/mkdir -p "/usr/local/hdf5-1.8.7_intel_12.1.2/bin"
 /usr/bin/install -c h5c++ '/usr/local/hdf5-1.8.7_intel_12.1.2/bin'
test -z "/usr/local/hdf5-1.8.7_intel_12.1.2/lib" || /bin/mkdir -p "/usr/local/hdf5-1.8.7_intel_12.1.2/lib" /bin/bash ../../libtool --mode=install /usr/bin/install -c libhdf5_cpp.la '/usr/local/hdf5-1.8.7_intel_12.1.2/lib'
libtool: install: warning: relinking `libhdf5_cpp.la'
libtool: install: (cd /media/dataspace/Downloads/hdf5-1.8.7/c++/src; /bin/bash /media/dataspace/Downloads/hdf5-1.8.7/libtool --silent --tag CXX --mode=relink icpc -O3 -ip -version-info 7:1:0 -L/usr/local/zlib-1.2.6_intel_12.1.2/lib -L/usr/local/szip-2.1_intel_12.1.2/lib -o libhdf5_cpp.la -rpath /usr/local/hdf5-1.8.7_intel_12.1.2/lib H5Exception.lo H5IdComponent.lo H5Library.lo H5Attribute.lo H5Object.lo H5PropList.lo H5FaccProp.lo H5FcreatProp.lo H5DcreatProp.lo H5DxferProp.lo H5DataType.lo H5DataSpace.lo H5AbstractDs.lo H5AtomType.lo H5PredType.lo H5EnumType.lo H5IntType.lo H5FloatType.lo H5StrType.lo H5ArrayType.lo H5VarLenType.lo H5CompType.lo H5DataSet.lo H5CommonFG.lo H5Group.lo H5File.lo ../../src/libhdf5.la -lsz -lz -lm ) /media/dataspace/Downloads/hdf5-1.8.7/libtool: line 8964: icpc: command not found libtool: install: error: relink `libhdf5_cpp.la' with the above command before installing it

So it seems I have a problem with icpc??

I also tried hdf5-1.8.8, but that gave me the same error.

I was wondering whether you have any idea what is wrong?

Kind regards,
Matthias

--
-------------------------------------------------------------
FWO Post-doctoral Research Fellow
KU Leuven
Department of Earth&   Environmental Sciences
Physical and Regional Geography Research Group
Regional climate studies

Celestijnenlaan 200E
3001 Heverlee (Leuven)
BELGIUM

Tel: + 32 16 326424
Fax: + 32 16 322980
matthias.demuzere@xxxxxxxxxxxxxxx

School of Geography and Environmental Science
Monash University
Melbourne, Victoria
Australia
Matthias.Demuzere@xxxxxxxxxx

http://geo.kuleuven.be/aow/
www.kuleuven.be/geography
http://www.watersensitivecities.org.au/about-us/people/profiles/dr-matthias-demuzere/
-------------------------------------------------------------