Re: [netcdf-hdf] [netcdfgroup] NetCDF: HDF error, and now what?

  • To: Ed Hartnett <ed@xxxxxxxxxxxxxxxx>
  • Subject: Re: [netcdf-hdf] [netcdfgroup] NetCDF: HDF error, and now what?
  • From: Rob Latham <robl@xxxxxxxxxxx>
  • Date: Tue, 25 Oct 2011 13:48:36 -0500
On Tue, Oct 25, 2011 at 10:41:50AM -0600, Ed Hartnett wrote:
> 
> What this is telling me is that this is not a HDF5 or netCDF problem,
> but that your MPI layer is throwing the error at the HDF5 library.
> 
> What MPI layer are you using? On what platform? Is there an alternative
> available?

Actually, it's even lower than that.  Turtles, man, all the way
down...

PSC runs lustre.  I don't know what other parallel file systems John
Urbanic has at PSC but he might want to try against GPFS (not nfs!)

If you are running MPICH2, try to run 1.4 or newer: the Lustre MPI-IO
driver has seen some bug fixes and improvements from the lustre
community. 

The recent MVAPICH2-1.7 release has these latest improvements

I think the most recent OpenMPI release has them too, but not in the
OpenMP-1.4 series.

anyway, yes, report back some more information about your environment.

==rob

-- 
Rob Latham
Mathematics and Computer Science Division
Argonne National Lab, IL USA