Re: distribution musings - install three libraries to get netcdf-4?

  • To: Ed Hartnett <ed@xxxxxxxxxxxxxxxx>
  • Subject: Re: distribution musings - install three libraries to get netcdf-4?
  • From: "Robert E. McGrath" <mcgrath@xxxxxxxxxxxxx>
  • Date: Wed, 3 Dec 2003 14:59:22 -0600
Looks OK for the start. We can revise it as we try it and find out what we left out.

On 2003.12.03 14:47 Ed Hartnett wrote:

Howdy all!

As I prepare the fist tarball for netcdf-4 I am musing about some
interesting distribution requirements we have.

Here's the section from the requirements (I just added the last one
this morning.) The entire requirements document can be found as always
at http://my.unidata.ucar.edu/content/software/netcdf/netcdf-4/reqs.html

Distribution with both netCDF and HDF5 packages

    * The netCDF-4 library is distrubuted by both Unidata and NCSA.


Sure.  I'm not sure of the details, but it should be simple.

    * The netCDF-4 library requires that HDF5 (version 1.8.0 or
      greater) be installed.

Hmm. There is no 1.8.0! We probably need 1.6.0 or above, unless there is
something I don't know about in netCDF4.


    * The netCDF-4 library can coexist peacefully with the netCDF-3
      library, but both cannot be used in the same program.

    * Potential users can select from a number of distributions,
      depending on whether they already have netCDF-3 and/or HDF5
      installed. Whatever the circumstance, users should be able to
      install netcdf-4 in one pass through the usual configure/make
      install/make check cycle.

Without actually trying, I can't really comment on how this should read.


What do we all think of those requirements. Anyone object to any, or
want to add to them?

Thanks,

Ed