LDM not starting up automatically

 I modified the start up script as you suggested in item 2 and LDM now
starts up automatically upon reboot.  Thanks for your help!

-----Original Message-----
Sent: Thursday, February 28, 2002 11:49 AM
Cc: ldm-users@xxxxxxxxxxxxxxxx

I am running Solaris 8 on a Sun machine, and had the same problem.  Look at
the following and see how to solve the problem.  It is correspondence with
Anne Wilson at Unidata, and how I solved the problem.  I think I moved my
.login file aside, and things ran fine.  It's not a perfect fix, but it
works and things have run smoothly since.  
Anne Wilson wrote:
Hi Patrick,

Here's another thought about the ldm not starting at boot problem.  I'm
wondering about the 'su -' aspect of the script that makes the shell a
login shell.  There are two things I'd like you to try:

1) Try moving just the .login file to the side and then rebooting.  

2) Keep .login in place, but modify the script as follows:

                /bin/su ldm -c "$LDMBIN/ldmadmin delqueue"
                /bin/su ldm -c "$LDMBIN/ldmadmin mkqueue"
#               /bin/su ldm -c "$LDMBIN/ldmadmin delsurfqueue"
#               /bin/su ldm -c "$LDMBIN/ldmadmin mksurfqueue"
                /bin/su ldm -c "$LDMBIN/ldmadmin start"

That is, take out the '-' argument to su.

The former does a login but doesn't execute your .login, and the latter
will not do a login at all.  Please let me know what happens.


----- Original Message ----- 
Sent: Thursday, February 28, 2002 11:23 AM

   I am having difficulty in getting LDM to start up automatically on my
machine running Solaris 8.  The really strange thing is that when I run the
start-up script manually, LDM starts up without any problems.  However,
whenever the machine is rebooted, LDM does not start even though it is using
the same start-up script.  I have checked ldmd.log and found no start
errors.  I have double-checked that the ownership of the files is user ldm
and not root.  I have verified that rpc is running fine by checking rpcinfo
-p.  What else should I check?  Thanks.

Mary Chang 
Information Management 
St. Paul District Corps of Engineers 
(651) 290-5489