Re: Not writing to ldmd.log - our solution


For several years, we have had problems on our machines (running
FreeBSD) in getting the ldm to write to the ldmd.log, even though
everything else always worked superbly. Last week, we installed
ldm-5.1.4 on our newest server and we still had this problem. Everything
worked fine except for the ability to write to ldmd.log file.

In doing some more testing and looking for solutions for getting the
ldmd to write to the ldmd.log file, we discovered that ldmd would write
to the logfile if we started rcp.ldmd from the command line by
specifying the log path/file, but not using ldmadmin.  As a result, we
were able to modify ldmadmin ever so slightly, so that now it works.

Here is the important diff comparisons between the non-working ldmd.log
logger and working one, when starting the ldm with ldmadmin:

%diff ldmadmin.ori ldmadmin

<     $cmd_line .= " -q $pq_path $ldmd_conf > $pid_file";
>     $cmd_line .= " -l $log_file -q $pq_path $ldmd_conf > $pid_file";

All it took was the addition of the "-l $log_file" to the $cmd_line
specification. It appears that ldmadmin was not automatically passing
this information onto rpc.ldmd, even if we specified the logfile info as
an option with ldmadmin. 

I thought that I would pass this on, since this problem has off and on
eaten up many hours of my time over the past several years and the
solution for us turned out to be so simple--argh!!!.

James P. Koermer             E-Mail: koermer@xxxxxxxxxxxxxxxxx
Professor of Meteorology     Office Phone: (603)535-2574
Natural Science Department   Office Fax: (603)535-2723
Plymouth State College       WWW:
Plymouth, NH 03264

  • 2001 messages navigation, sorted by:
    1. Thread
    2. Subject
    3. Author
    4. Date
    5. ↑ Table Of Contents
  • Search the ldm-users archives: