[idvusers] ERROR in linking netcdf libraries (ld: 0711-317 ERROR: Undefined symbol: .nf_open)

hi,
    I have installed netcdf version 4.1.3 . I ran make check and i did not
get any error and my netcdf installation was fine. i used disable netcdf 4
option during configuring netcdf. But when i compile some program involving
netcdf commands like nf_open or NF90_OPEN .,etc i get the following errors.


**** Compiling ARWpost ****

        xlf90_r -qfree=f90 -L/home/mandal/arun/lib -lm -o ARWpost.exe
module_model_basics.o constants_module.o gridinfo_module.o ARWpost.o
input_module.o output_module.o module_map_utils.o misc_definitions_module.o
module_date_pack.o module_debug.o process_domain_module.o
module_get_file_names.o module_interp.o module_basic_arrays.o
module_diagnostics.o module_arrays.o module_pressure.o module_calc_height.o
module_calc_pressure.o module_calc_theta.o module_calc_tk.o
module_calc_tc.o module_calc_td.o module_calc_td2.o module_calc_rh.o
module_calc_rh2.o module_calc_uvmet.o module_calc_slp.o module_calc_dbz.o
module_calc_cape.o module_calc_wdir.o module_calc_wspd.o
module_calc_clfr.o   -L/home/mandal/arun/netcdf/lib
-I/home/mandal/arun/netcdf/include  -lnetcdf
ld: 0711-317 ERROR: Undefined symbol: .nf_open
ld: 0711-317 ERROR: Undefined symbol: .nf_inq
ld: 0711-317 ERROR: Undefined symbol: .nf_inq_dim
ld: 0711-317 ERROR: Undefined symbol: .nf_inq_var
ld: 0711-317 ERROR: Undefined symbol: .ncvgt
ld: 0711-317 ERROR: Undefined symbol: .nf_get_att_text
ld: 0711-317 ERROR: Undefined symbol: .nf_get_att_int
ld: 0711-317 ERROR: Undefined symbol: .nf_get_att_real
ld: 0711-317 ERROR: Undefined symbol: .nf_inq_attname
ld: 0711-317 ERROR: Undefined symbol: .nf_inq_att
ld: 0711-317 ERROR: Undefined symbol: .nf_close
ld: 0711-317 ERROR: Undefined symbol: .nf_inq_varid
ld: 0711-317 ERROR: Undefined symbol: .nf_get_vara_text
ld: 0711-317 ERROR: Undefined symbol: .nf_get_var_real
ld: 0711-345 Use the -bloadmap or -bnoquiet option to obtain more
information.
make: 1254-004 The error code from the last command is 8.
make: 1254-005 Ignored error code 8 from last command.
Target "all" is up to date.


Please help me find my problem. Is the problem in setting my linker flag ,
cflag paths or with my netcdf installation ?


with regards,
ARUN RAMANATHAN.S