Re: [idvusers] Did anyone successfully run the initial 2.7u1 release with Java 6 on Leopard?

Thanks!  Solution #1 worked like a charm!

On Jul 15, 2009, at 5:15 PM, Martin Otte wrote:

Hi,

Do you have the latest java update from Apple? If so, then you can try:

1) To run IDV.app with 64-bit Java SE 6 on OSX, you have to update the
JavaApplicationStub that comes with IDV. The architecture of this file
determines what version of java to use, but the version shipped with
IDV only has ppc and i386 architectures (not x86_64).

You can just copy the universal Java stub installed with the operating
system.
If IDV was installed in /Applications/IDV_2.7u1, then:

cp /System/Library/Frameworks/JavaVM.framework/Resources/MacOS/
JavaApplicationStub /Applications/IDV_2.7u1/IDV.app/Contents/MacOS/

You should then able to double-click IDV.app and it will run in 64- bit.


2) For command-line java programs, don't mess with the java symlinks.
If you set Java SE 6 64-bit as the preferred java version in the Java
Preferences, then you can put:

export JAVA_HOME=$(/usr/libexec/java_home)

in your .bashrc to set the correct JAVA_HOME environment variable.


3) If you set the preferred java version, you can run idv from the
command line in 64-bit mode too. Assuming IDV was installed in /
Applications/IDV_2.7u1, then you can try:

java -server -Xmx1024m -Xdock:name=IDV -jar Applications/IDV_2.7u1/
idv.jar

This should run IDV in 64-bit mode regardless of whether you updated
the IDV.app binary.


Hope this helps,

Martin Otte
Duke University
Civil and Environmental Engineering


On Jul 15, 2009, at 4:07 PM, Christopher Lynnes wrote:

When IDV 2.7u1 first came out (before the recompile), I tried the
Java 6 upgrade approach in Mac OS X 10.5.7.  This turned out to be
more complicated than anticipated, and I still had only a hacked
solution.  Here is what I did:

(1) Installed the recommended update and restarted:  no luck
(2) Tried aliasing java to the binary java in the Java 6 directory,
verified version with java -version and restarted: no luck
(3) Found the Applications/Utilities/Java Preferences utility and
moved Java SE 6 64-bit to the top of the stack, and restarted: no luck
(4) Began hacking runIDV:
 (a) added java alias from #2 above and ran: no luck
 (b) discovered that JAVA_HOME was searched first, so I added
JAVA_HOME=/System/Library/Frameworks/JavaVM.framework/Versions/1.6/
Home

Success!  Sort of...
...because I still cannot run IDV.app, even after setting JAVA_HOME
in my .bash_profile.

Did anyone get this to work with Java 6 in Leopard, and if so,
what's your secret?
--
Christopher Lynnes             NASA/GSFC, Code 610.2
301-614-5185

_______________________________________________
idvusers mailing list
idvusers@xxxxxxxxxxxxxxxx
For list information, to unsubscribe, visit: 
http://www.unidata.ucar.edu/mailing_lists/

_______________________________________________
idvusers mailing list
idvusers@xxxxxxxxxxxxxxxx
For list information, to unsubscribe, visit: 
http://www.unidata.ucar.edu/mailing_lists/

--
Christopher Lynnes NASA/GSFC, Code 610.2 301-614-5185