Re: support for IDV 1.2 on MacOS X 10.4

  • Subject: Re: support for IDV 1.2 on MacOS X 10.4
  • From: "John C Cartwright" <John.C.Cartwright@xxxxxxxx>
  • Date: Mon, 10 Oct 2005 09:35:06 -0600
Thanks to all for the clarification. IDV 1.2 does indeed seem to work w/ JDK 1.4.2 on Mac OS X 10.4. Rolling back from 1.5 to 1.4.2 is just a matter of changing the CurrentJDK symlink.

I'm still looking into ways to be able to use 1.4.2 w/ IDV w/o changing that link.

-- john


Mark J. Laufersweiler wrote:
I am running the IDV on my Mac (10.4.2) BUT with java 1.4. I checked
with the developers when the Apple update to 1.5 came out. They
confirmed and it is listed on the link that Tom sent you IDV does
not work with 1.5.

Not sure how hard it will be, but you will need to back out of java
1.5  to 1.4.whatever.

mjl


On Fri, 7 Oct 2005, John C Cartwright wrote:


Thanks for your prompt reply, Tom.  I did see that note, and it would
seem from Apple that Java3D is not available on 10.4.

However, I had heard elsewhere that Java3D was "built-in" to 10.4 -
hence my confusion.

I did install IDV 1.2 on my Mac, but it throws all kinds of exceptions
and I hoping someone else might have previously travelled this road.

Did I understand correctly that your cube-mate's mac seemed to work OK
w/ 1.2 and 10.4?

Thanks again!

-- john


Tom Whittaker wrote:

Hi John:

If you check out this page:
<http://www.unidata.ucar.edu/software/idv/docs/userguide/Systems.html>

you will see that you need to install Java3D (section 1.1.0, at the ****
note).  There is also a link to get it.  My only experience with IDV on
Macs, however, has been limited to alittle testing on my cube-mates Mac,
and I've only used the WebStart version.

tom

John C Cartwright wrote:


Hello,

I'm a little confused about support on MacOS 10.4. I have java 1.5
installed, but it's unclear to me whether Java3D is built into it or
available separately. IDV 1.2 doesn't seem to work as is.

Can someone clarify for me?

Thanks!

-- john