[gembud] > 2GB files

Kevin,

Solaris has been 64-bit for years and I can't read GFS 0.5 filed that are 
larger than 2GB. Is there something in the config prior to compile process that 
allows GEMPAK to read 2GB+ files?

Thanks,
Robert Mullenax

CSBF Meteorology





-----Original Message-----
From: gembud-bounces@xxxxxxxxxxxxxxxx on behalf of Tyle, Kevin R
Sent: Wed 4/30/2014 4:48 PM
To: Charles Zachary Smith
Cc: gembud@xxxxxxxxxxxxxxxx
Subject: Re: [gembud] gdlist gdplot2 problems
 
Hmm, I'll rig up a similar pqact and see what I see on my end.  

I don't think GEMPAK should have any problem reading a 2GB grid, as long as you 
are using a 64-bit version of the software on a 64-bit OS.  We can read from 
HRRR GEMPAK files that are typically of size 2.2-2.5 GB without any problem ...

The "can not decode" errors are just from GRIB2 fields that don't have a match 
in the grib tables in $GEMTBL/grid ... with a little research those ought to be 
able to be resolved.

_____________________________________________
Kevin Tyle, Systems Administrator 
Dept. of Atmospheric & Environmental Sciences   
University at Albany
Earth Science 235, 1400 Washington Avenue                        
Albany, NY 12222
Email: ktyle@xxxxxxxxxx
Phone: 518-442-4578                             
_____________________________________________


-----Original Message-----
From: Charles Zachary Smith [mailto:czsmith@xxxxxxx] 
Sent: Wednesday, April 30, 2014 5:41 PM
To: Tyle, Kevin R
Subject: Re: [gembud] gdlist gdplot2 problems

I am not sure if I am supposed to reply to all, but it appears to be a decoding 
problem, although I am not sure what is causing it.

The file is piped through the LDM via this action, which should work.
NGRID|CONDUIT   (^[LM].B... KWBE|prod/nam.*awip12)
        PIPE    /opt/gempak/GEMPAK7/os/linux64/bin/dcgrib2 -d 
/atmo/data/gempak/logs/dcgrib2_NAM218.log
                -e GEMTBL=/opt/gempak/GEMPAK7/gempak/tables

We're also starting to store data in grib2 format data as well.  I figured I 
could just write another action.
CONDUIT prod/nam\.(........)/nam\.t(..)z\.awip12(..)
        FILE    -log /atmo/data/gempak/model/nam12km/grib2/\1\2_fh_\3.grib2

which appears to be working.


Here is small part of my log for the decoding into gem format.

[7000] 121113/1953[DECODE_GRIB2 -34] Could not determine parameter name 0 0 195 
8 [876098097] [7000] 121113/1953[GB -1]  No GRIB record was found.
[7000] 121113/1953[DECODE_GRIB2 -34] Could not determine parameter name 0 2 2 0 
[0] [7000] 121113/1953[GB -1]  No GRIB record was found.
[7000] 121113/1953[DECODE_GRIB2 -34] Could not determine parameter name 0 2 3 0 
[0] [7000] 121113/1953[GB 1]  No GEMPAK parameter name defined for this grid.
[7000] 121113/1953[DECODE_GRIB2 -34] Could not determine parameter name 0 2 222 
8 [892547123] [7000] 121113/1953[GB 1]  No GEMPAK parameter name defined for 
this grid.
[7000] 121113/1953[DECODE_GRIB2 -34] Could not determine parameter name 0 16 
197 0 [808792373] [7000] 121113/1953[GB 1]  No GEMPAK parameter name defined 
for this grid.
[7000] 121113/1953[DECODE_GRIB2 -34] Could not determine parameter name 0 2 224 
0 [842478385] [7000] 121113/1953[GB 1]  No GEMPAK parameter name defined for 
this grid.
[7000] 121113/1953[DECODE_GRIB2 -34] Could not determine parameter name 0 5 194 
0 [926430516] [7000] 121113/1953[GB -1]  No GRIB record was found.
[7000] 121113/1953[DECODE_GRIB2 -34] Could not determine parameter name 0 3 5 0 
[0] [7000] 121113/1953[GB 1]  No GEMPAK parameter name defined for this grid.
[7000] 121113/1953[DECODE_GRIB2 -34] Could not determine parameter name 0 2 223 
8 [959658294] [7000] 121113/1953[GB -1]  No GRIB record was found.
[7000] 121113/1953[DECODE_GRIB2 -34] Could not determine parameter name 0 3 5 0 
[0] [7000] 121113/1953[GB -1]  No GRIB record was found.
[7000] 121113/1953[DECODE_GRIB2 -34] Could not determine parameter name 0 3 5 0 
[0] [7000] 121113/1953[GB 1]  No GEMPAK parameter name defined for this grid.
[7000] 121113/1953[DECODE_GRIB2 -34] Could not determine parameter name 0 0 196 
8 [842609462] [7000] 121113/1953[GB 1]  No GEMPAK parameter name defined for 
this grid.
[7000] 121113/1953[DECODE_GRIB2 -34] Could not determine parameter name 0 1 27 
8 [909523249] [7000] 121113/1953[GB 1]  No GEMPAK parameter name defined for 
this grid.
[7000] 121113/1953[DECODE_GRIB2 -34] Could not determine parameter name 0 1 198 
8 [875640374] [7000] 121113/1953[GB 1]  No GEMPAK parameter name defined for 
this grid.
[7000] 121113/1953[DECODE_GRIB2 -34] Could not determine parameter name 0 4 197 
0 [825767985] [7000] 121113/1953[GB 1]  No GEMPAK parameter name defined for 
this grid.
[7000] 121113/1953[DECODE_GRIB2 -34] Could not determine parameter name 2 4 2 0 
[943208240] [7000] 121113/1957[GB 1]  No GEMPAK parameter name defined for this 
grid.

Charles

----- Original Message -----
From: "Kevin R Tyle" <ktyle@xxxxxxxxxx>
To: "Charles Zachary Smith" <czsmith@xxxxxxx>, gembud@xxxxxxxxxxxxxxxx
Sent: Wednesday, April 30, 2014 4:30:34 PM
Subject: RE: [gembud] gdlist gdplot2 problems

Hi Charles,

My guess is that the GEMPAK grid did not get created properly.  Its header 
might be correct, which is why gdinfo shows it, but it may not have any 
meaningful information in it so none of the plotting programs work.

What version of GEMPAK are you running? Did you create the GEMPAK grid file 
yourself (i.e. using dcgrib2 or nagrib2 from the GRIB2 file) or is it 
automatically received in your department?

If you have IDV, try pointing it to that grid file and see if it can display 
anything.

--Kevin

_____________________________________________
Kevin Tyle, Systems Administrator 
Dept. of Atmospheric & Environmental Sciences   
University at Albany
Earth Science 235, 1400 Washington Avenue                        
Albany, NY 12222
Email: ktyle@xxxxxxxxxx
Phone: 518-442-4578                             
_____________________________________________


-----Original Message-----
From: gembud-bounces@xxxxxxxxxxxxxxxx [mailto:gembud-bounces@xxxxxxxxxxxxxxxx] 
On Behalf Of Charles Zachary Smith
Sent: Wednesday, April 30, 2014 5:24 PM
To: gembud@xxxxxxxxxxxxxxxx
Subject: [gembud] gdlist gdplot2 problems

Hello,

I am trying to plot some basic grids with gdplot2, although I have run into 
some trouble.

I first used gdinfo to see if the grid existed and I believe it does in my 
attached terminal output.
However,  when I run gdlist on the same exact arguments,  I receive this error

 [DG -7]  Input grid TMPK ^140430/1800F084 @500 %PRES cannot be found.

which doesn't make any sense because GDINFO shows the grid in this file.
Does anyone have any idea what I am doing wrong?

I receive the same error in gdplot2.

Thanks,
Charles
_______________________________________________
gembud mailing list
gembud@xxxxxxxxxxxxxxxx
For list information or to unsubscribe,  visit: 
http://www.unidata.ucar.edu/mailing_lists/