Re: [gembud] GEMPAK for OS X 10.8 (Mountain Lion)

I was able to successfully build GEMPAK on OS X Mountain Lion.

I don't think freetype properly installed for me (I sent my installation notes 
to Kevin so I don't remember), but when I ran ./configure on OpenMotif, I was 
able to get it to successfully build. My issue was I left off the ./ part of it.

Some of the supplemental packages Kevin mentioned didn't fully install for me 
either, but enough did to successfully build GEMPAK.

Nathan Parker
WeatherBug Backyard Support


  1. GEMPAK for OS X 10.8 (Mountain Lion) (Michael James)


----------------------------------------------------------------------

Message: 1
Date: Wed, 7 Nov 2012 18:23:10 -0700
From: Michael James <mjamesis@xxxxxxxxx<mailto:mjamesis@xxxxxxxxx>>
To: GEMBUD <gembud@xxxxxxxxxxxxxxxx<mailto:gembud@xxxxxxxxxxxxxxxx>>
Subject: [gembud] GEMPAK for OS X 10.8 (Mountain Lion)
Message-ID:
<CAHqyXPehHJxpFzSwNeXHK8YaHS2akr4djdpixgdkSv-ieVfr_g@xxxxxxxxxxxxxx<mailto:CAHqyXPehHJxpFzSwNeXHK8YaHS2akr4djdpixgdkSv-ieVfr_g@xxxxxxxxxxxxxx>>
Content-Type: text/plain; charset=ISO-8859-1

I found a problem, and a solution, for building Open Motif (and
GEMPAK) on OSX 10.8 Mountain Lion.

Firstly, Xcode does not install the command line tools by default
anymore, so they must be installed manually in Xcode Preferences (on
the Downloads tab).

Secondly, ftheader.h (freetype) is not found when running "./configure
--prefix=/opt/local" because the header file is actually at
/opt/local/include/freetype2/freetype/ftheader.h - a bug mentioned
many times online.

Moving the directory "freetype" down one directory to
/opt/local/include/freetype/ (instead of
/opt/local/include/freetype2/freetype/) allows it to be recognized by
the open motif build.

I also tried instead to run "./configure
--prefix=/opt/local/include/freetype2/" instead of "./configure
--prefix=/opt/local/" and it seems to work, but I'm not confident that
this is a fix for first-time installation of the libraries with
macports.

Anyone care to try with 10.8 and let the rest of us know?

Thanks,

Michael