[gembud] FW: no data written by dc* progs

FOR THE RECORD:  Fixed!

I have no idea why this worked.  I re-generated my LDM pqact.* files from the 
gen_pqact.csh script instead of the gen_pqact_GEMDATA.csh script.  For whatever 
reason, the dc* decoders like to dump the decoded .gem files into the 
$LDMHOME/data symlink.  I just created another sym link inside $LDMHOME/data 
and pointed it to where I wanted the data to go, and now all is well.

HUGE THANKS  to Michael James for taking the time to look into this for me!

-Mike-


________________________________
From: Michael James [mailto:mjamesis@xxxxxxxxx]
Sent: Monday, June 25, 2012 8:24 AM
To: Van Tress,Michael J (BPA) - PGPW-5
Subject: Re: [gembud] no data written by dc* progs

does this happen with all decoders or just some - are you getting at least some 
data ingested and written, and if that's the case, are the data written using 
FILE or PIPE in their pqact.conf entries?

Michael


On Mon, Jun 25, 2012 at 9:13 AM, Van Tress,Michael J (BPA) - PGPW-5 
<mjvantress@xxxxxxx<mailto:mjvantress@xxxxxxx>> wrote:
Mike...

I've disabled SELINUX, and am still no able to write.  Here are some of the dc* 
logs:

Enormous Thanks for looking into this!  Please don't spend too much time on 
this.  I was hoping that there was already a fix.
Again, thank you for looking into this.  I'm very greateful for your time!

-Mike-


________________________________
From: Michael James [mailto:mjamesis@xxxxxxxxx<mailto:mjamesis@xxxxxxxxx>]
Sent: Friday, June 22, 2012 11:54 AM
To: Van Tress,Michael J (BPA) - PGPW-5
Subject: Re: [gembud] no data written by dc* progs

Michael, can you send me the log file which contains these "can not write to 
file" messages?

Also is SELINUX enabled or disabled?



On Fri, Jun 22, 2012 at 12:32 PM, Van Tress,Michael J (BPA) - PGPW-5 
<mjvantress@xxxxxxx<mailto:mjvantress@xxxxxxx>> wrote:
I've noticed from the past posts that this has been a problem, but I don't see 
a post with a solution.
Is there a soltuion?  I'd be very greateful if someone would share if there is.

I've disabled ipv6 on our system.

Here's a previous description that fits mine to the tee:

I've run into a problem with 5.11.4 where the decoders will not write files 
into $GEMDATA. If I wipe out the directory structure, the progs will create all 
of the proper subdirectories, but they will not be populated with data. In the 
various log files, all the apps complain about not being able to write to 
files. I've double checked the write permissions on the directories and ldm has 
write permissions (gempak was built under the ldm account, no gempak user.)
My system is:  Redhat Enterprise 4
Kernel is:   2.6.9-89.ELsmp #1 SMP Mon Apr 20 10:34:33 EDT 2009 i686 i686 i386 
GNU/Linux
There were no errors in the make or make_install logs that I could tell.



_______________________________________________
gembud mailing list
gembud@xxxxxxxxxxxxxxxx<mailto:gembud@xxxxxxxxxxxxxxxx>
For list information or to unsubscribe,  visit: 
http://www.unidata.ucar.edu/mailing_lists/