Re: [gembud] n-progs problems on Fedora 12 x86_64

Hi Ben,

I suspect that your openmotif is 2.3.2 or greater. You will need to install openmotif <= 2.3.1 for nmap2 functionality to return (and, I suspect, the other nprogs as well).

I'm curious as to what changed with 2.3.2, and if it's an openmotif problem or whether some heretofore coding issue in N-AWIPS has been exposed. Things still don't work with 2.3.3, at least when I tried it on my OS X build.


On 04/07/2010 07:50 PM, Ben Cotton wrote:
I tried building GEMPAK 5.11.4 on my Fedora 12 x86_64 machine but I've
run into an interesting problem.  nmap2 has no icons and it is
impossible to load data.  Nalarm works fine until I try to open a new
product and then the buttons are so large that the product is not
visible.  Nwx behaves similarly.

nmap2 screenshot:

naltxt screenshit:

To build, I installed the libXp-devel, libX11-devel, openmotif-devel,
and xorg-x11-fonts-ISO8859-1-75dpi packages and edited
Makeinc.linux64_gfortran to point to /usr/include/openmotif for the
MOTIFINC directory, and to /usr/lib64/openmotif for X11LIBDIR.

I didn't find any obvious problems in make.out, so I've made it
available on the Intertubes in case anyone can use it to make sense of
what I'm seeing:


  • 2010 messages navigation, sorted by:
    1. Thread
    2. Subject
    3. Author
    4. Date
    5. ↑ Table Of Contents
  • Search the gembud archives: