Re: [gembud] Segmentation Fault in gpnexr2 (and gpnexr2_gf) in version 5.11.1

Mina,

This won't be of any help, but will at least verify that someone else is
experiencing the same issue.  I used the exact settings you had below using
the attached file and had the same segmentation fault on both a 32-bit
CentOS running 5.11.1 and 64-bit RH Linux running 5.11.4.  I also tried to
use the example settings at
(http://www.unidata.ucar.edu/cgi-bin/gempak/manual/programs_index?gpnexr2)
and got the same segmentation fault.  This file worked fine in IDV.

Regards,
Evan Lowery

-----Original Message-----
From: gembud-bounces@xxxxxxxxxxxxxxxx
[mailto:gembud-bounces@xxxxxxxxxxxxxxxx] On Behalf Of Mina Azer
Sent: Monday, June 22, 2009 12:07 PM
To: gembud@xxxxxxxxxxxxxxxx
Subject: [gembud] Segmentation Fault in gpnexr2 (and gpnexr2_gf) in version
5.11.1

The problem is that gpnexr2 is producing a seg fault when I try to create an
image using the attached radar file.

The settings are:
 MAP      = 10=100:100:100//2 + 8 + 9
 GAREA    = 39.9;-75.5;41;-73.4
 PROJ     = RAD
 RADFIL   = KDIX_20090615_1940
 LATLON   = 0
 PANEL    = 0
 TITLE    = 1
 TEXT     = .8/2/////HW
 CLEAR    = YES
 DEVICE   = xw
 LUTFIL   = /home/user/wxscripts/lev2rad.tbl
 IMCBAR   = 31/V/LL/.005;.05/.85;.01|.7/1/1/hw
 TILT     = .5
 RADPARM  = dz
 RADTIM   = current

IDV is able to process the radar file fine.

The seg fault occurs with both 5.11.1 and 5.11.4, but I don't know about
version 5.11.4 of gpnexr2_gf since those executables haven't been compiled.

A related query involves the white blotches that sometimes appear on the
radar plots of Level II data with gpnexr2.  How do we get rid of those?

A final query is that it doesn't seem like the resolution has increased to
250m in 5.11.4.  How does one go about achieving the increased resolution?

Thanks,