[gembud] GEMPAK installation woes

Hi,

I'm trying to install GEMPAK on a Debian x64 system, but have run into a few problems. I've looked through mailing list archives but couldn't seem to find the same difficulties.

I first attempted to simply use the binary packages. A number of things seem to work, including the decoders. I'm primarily interested in the graphical applications which have a couple of difficulties though. A few of the applications like garp and nsharp seem to work, but the toolbar buttons are completely blank, making operation difficult. Nmap2 seg faults right after the window opens.

Thinking it would work better if I compiled from source, that's what I tried next. I ran into a few problems with missing Motif dev files, which were fixed after a bit of head scratching. There are a couple of problems left in the compilation however, including the insistence on using gfortran for some reason. I've changed the lines in Gemenviron to read:

#set USE_GFORTRAN=1
#set USE_PGI=1
set USE_G77=1

But it still comes up with dozens of errors saying gfortran is not found before stopping. The make.out file (409K) is at:

http://people.iarc.uaf.edu/~austin/make.out

Any help in getting either the binary or source distributions to work is greatly appreciated.


Thanks,
Austin

--
Austin Cross
Graduate Student / Research Assistant
International Arctic Research Center
University of Alaska Fairbanks
Phone: 907-474-2415