RE: GEMPAK 5.9.4: QBUF Crashes nmap2

Brent,

You appear to be having a problem with the redirection of the bufr
logging from stderr to /dev/null. The sporadic behavior depends on
whether the attempt to open /dev/null fails. The 5.9.4 distribution uses
the melBUFR library supplied with GEMPAK,
where previously I had utilized separate routines (that is why you see
additional
log messages with the 5.9.4 distribution).

I have re-written that code and tested. The distribution files are being
reposted to
the download area at this time.

Steve Chiswell
Unidata User Support


On Tue, 2006-11-28 at 14:36 -0600, Brent Shaw wrote:
For what it's worth, I have done some more testing of this.  The QBUF
data doesn't always crash nmap2 right away.  Sometimes it loads for a
split second (you see a flash of the plots), then crashes.  Sometimes I
am able to load it just fine, animate it, etc.  But, if I then try
loading it again or loading additional frames, it will crash.
I tried running the pre-compiled version with the same result.  For now,
we are back to running 5.9.3, which works fine with the QBUF data.
Regards,

Brent

-----Original Message-----
From: Brent Shaw Sent: Tuesday, November 21, 2006 4:32 PM
To: gembud@xxxxxxxxxxxxxxxx
Cc: chiz@xxxxxxxxxxxxxxxx
Subject: GEMPAK 5.9.4: QBUF Crashes nmap2

Hello all,

Our upgraded to 5.9.4 was pretty smooth, except that now when loading
QBUF products (QuikSCAT BUFR from NOAAPORT), nmap2 crashes.  The same
exact data files work fine with 5.9.3.  Under 5.9.4, in my window where
I started NTL, I get some messages (below) that I don't get with 5.9.3.
Anybody else tried QBUF with this new release?
Best regards,
Brent

--- output from 5.9.4 when loading QBUF ....
Finished reading tables...
Resource File:  /home/brents/GEMPAK5.9.4/resource/Nmap
BUFR LOG: Tue Nov 21 22:24:42 2006
Processing file /DATA/nawips/gempak/qsct/2006112116.bufr
log file = stdout
 <<< Current settings of flags in BUFR_Cntl >>>
    Auto FTP not allowed
    Duplication of table entries allowed
    No warnings of duplication of table entries printed
    BUFR log written to stdout
    New Table B & D entries are not printed
   Message containing new table entries not dumped
    Returned Code table entries indicatting missing are
         replaced by default value for missing
    Missing values are not replaced by default value for missing
Reading Table B
(/home/brents/GEMPAK5.9.4/gempak/tables/melbufr/B3M-000-006-B)
Reading Table D
(/home/brents/GEMPAK5.9.4/gempak/tables/melbufr/B3M-000-006-D)
Reading Table B
(/home/brents/GEMPAK5.9.4/gempak/tables/melbufr/B3L-160000-006001-B)
Reading Table D
(/home/brents/GEMPAK5.9.4/gempak/tables/melbufr/B3L-160000-006001-D)
--
Steve Chiswell <chiz@xxxxxxxxxxxxxxxx>
Unidata