Re: 20060123: Linking to GEMPAK libraries


Those routines are all in gemlib.a, however, it appears that you
didn't compile your code using the g77 flag -fno-second-underscore.
See the $CONFIGDIR/Makeinc.darwin for compilations flags you should
be using with your own code.

Steve Chiswell
Unidata User Support

Compiling with these flags worked.  Thanks.  There were, of course, a
few other "gotchas" porting it from HP fortran to g77 ;-)



I've noticed that for recent versions of GEMPAK, I've had to add a call to the library cgemlib.a in addition to gemlib.a.

Hope that helps.

-Mike
--
Dr. Michael J. Brennan
UCAR Visiting Scientist
NOAA/NWS/Tropical Prediction Center
Email: Michael.J.Brennan@xxxxxxxx
Phone: (305) 229-4439

Linking with cgemlib.a worked...except that I found that it must follow
the link to gemlib.a and not precede it.  My links were done in
alphabetical order the first time and it failed.


David

+------------------------------------------------------------------------+
| David O. Blanchard  Flagstaff, Arizona  david_blanchard@xxxxxxxxxxxxx  |
+------------------------------------------------------------------------+