Re: netCDF-Java 2.2.10

I just tried to clean up the source build.
Get the latest 2.2.10 and try this:

BUILD AND RUN FROM SOURCE
1. get the source release (ncSrc-2.2.10.zip)
2. unzip into working directory
3. ant compileUI
4. sh runSrcRelease

Let me know what doesnt work for you.
thanks

Robert B. Schmunk wrote:

Hi John,

I had thought about trying to compile netCDF from scratch, but tracing down all the package dependencies makes things such a hassle that I was putting it off until it became inescapable. But I may take a whack at it soon. I'll let you know
what happens if I do.

iText seems to be very much under development. Version 1.3.4 was released a week or two ago, and the author of the package is in the middle of writing a book/manual
right now.

I've just been examining the iText problem, and I am coming to the suspicion that it's something to do with Apple's Java 1.4 implementation. Stacktracing the errors gets deep into the Aqua L&F and the Sun font classes; the crashes are not in iText code itself. I was able to get Panoply to write a plot out to
PDF a few minutes ago after hacking a line in the iText source (yes,  I got
desperate enough to try compiling that package from source) to watch for bad input from a L&F class, but all the typefaces in the result were somehow been
converted to Helvetica. :(

rbs



On Oct 4, 2005, at 16:07, John Caron wrote:

Hi Robert:

Yes, its true we are using some 1.4 stuff like the URI class. Im not sure what else, its been a long time since I've run 1.3. It may be that the "minimal" netcdf library will work ok on 1.3 though. It would need to be recompiled under 1.3. If you want to try that, download the soruce distribution, and just compile ucar.ma2 and ucar.nc2. I _think_ it will work.

Generally 1.4 is better, faster, and less buggy than 1.3, im surprised that iText has problems. Is there anyone developing that still?

Sorry for not documenting this, I will update the web page.

Robert B. Schmunk wrote:

John,
Is it the case that using the netCDF-Java library version 2.2.x _requires_
the user have Java 1.4 installed?
I decided to take a look at upgrading Panoply from using nj-2.1.9 to the current stable nj-2.2.10. After 15-20 minutes of mucking about figuring out the changes in the API which specifically affected Panoply, I got the app back up and running... but only when I instructed it to use Java 1.4. When
I limit it to using Java 1.3, I get the following error:
gov.nasa.giss.panoply.Panoply.main(String[]) threw an exception:
java.lang.UnsupportedClassVersionError: ucar/nc2/dataset/ NetcdfDataset (Unsupported major.minor version 48.0) There is nothing on netCDF-Java homepage to indicate the particular level of Java required, so if 2.2.x requires a particular Java you may want to
update the website to explicitly say so.
This is probably not a big problem. I'd prefer to bump Panoply up to Java
1.4 anyway, but I have also run into a problem with another 3rd party
libary (the iText PDF writer) which crashes under Java 1.4 when run on Mac OS X. (If it's not one thingsit's another...) Also, Panoply is used in a number of classroom situations and one just never knows how up-to- date their
machines are being kept.
rbs
--
Robert B. Schmunk, rschmunk@xxxxxxxxxxxxx
NASA Goddard Institute for Space Studies, 2880 Broadway, New York, NY 10025



--
Robert B. Schmunk, rschmunk@xxxxxxxxxxxxx
NASA Goddard Institute for Space Studies, 2880 Broadway, New York, NY 10025