Re: Version 2.2 (alpha)

Bush, James S. wrote:

John,

I was hoping you could point me in the right direction. I am experimenting with the v2.2 Alpha specifically because I wanted to see how it read NEXRAD level three NIDS files. I have not yet been successful. Should the library be able to handle that type yet? Is NEXRAD Level 3 one of the native types in v2.2 or do I need to register it? Is there possibly a java snippet somewhere that I could look at? Sorry if this is covered somewhere in the docs. I did an initial reading and may have missed the topic due to my unfamiliarity with the API.

Thanks

Jim

James S. Bush

Chief Systems Engineer

SAIC/NSS

Herndon VA

703.796.3233


------------------------------------------------------------------------

Hi James:

yes, version 2.2.06 should work on NIDS data; its already registered.

Just open it as if its a netcdf file, eg

   NetcdfDataset ncfile = null;
   try {
     ncfile = NetcdfDataset.openDataset( location, addCoords, task);
     if (ncfile == null) {
JOptionPane.showMessageDialog(null, "NetcdfDataset.open cant open "+location);
     }
   } catch (IOException ioe) {
JOptionPane.showMessageDialog(null, "NetcdfDataset.open cant open "+ioe.getMessage());
   }

or try it in the ToolsUI program.

sorry the documentation not yet very complete.

if you have problems, send me the error message and/or the file.