[ldm-users] Downstream LDM Problems

Hi Everyone,

We are getting ready to upgrade to a new machine and are in the process of 
installing LDM 6.9.8 and have run into a couple of snags.   I apologize if the 
answers to these questions are somewhat elementary.

Right now we have the new machine (Twister2) as the downstream LDM to the 
current machine(Twister); however, we can't seem to send anything to the new 
machine.  

Our setup is as follows: 


                Upstream LDMs for Twister
                                |
============ FIREWALL ============
                                |
                                |
        Twister (twister.sbs.ohio-state.edu -- LDM v. 6.7.0)
                                |
                                |
        Twister2 (128.146.191.17 -- twister2.sbs.ohio-state.edu not active on 
DNS yet -- LDM v. 6.9.8) 

I can't even find the LDM logs on Twister2 for some reason (ran 
--enable-logging=local0 when configuring & ldmd.log is empty nor is there any 
info in /var/log/messages), but in Twister's LDM logs I found that Twister2 can 
connect, but we receive the following error (just once per ldmadmin start 
occurrence):

LDMD.LOG OUTPUT FROM  TWISTER: 

Jul 08 05:41:45 twister 128.146.194.17(feed)[26069] NOTE: Starting Up(6.7.0/6): 
20110708054322.793 TS_ENDT {{ANY,  ".*"}}, 
SIG=0908bdc773bda996582bd23bf9192761, Primary 
Jul 08 05:41:45 twister 128.146.194.17(feed)[26069] NOTE: topo:  128.146.194.17 
{{ANY, (.*)}} 
Jul 08 05:43:51 twister 128.146.194.17(feed)[26069] ERROR: Couldn't flush 
connection; nullproc_6() failure to 128.146.194.17: RPC: Unable to receive; 
errno = Connection reset by peer 
Jul 08 05:43:51 twister rpc.ldmd[25241] NOTE: child 26069 exited with status 6 


NOTIFYME OUTPUT FROM TWISTER2 TO TWISTER: 

[ldm@twister2 ~]$ notifyme -vl - -h twister.sbs.ohio-state.edu
Jul 08 16:02:16 notifyme[27739] NOTE: Starting Up: twister.sbs.ohio-state.edu: 
20110708160216.486 TS_ENDT {{ANY,  ".*"}}
Jul 08 16:02:16 notifyme[27739] NOTE: LDM-5 desired product-class: 
20110708160216.486 TS_ENDT {{ANY,  ".*"}}
Jul 08 16:02:16 notifyme[27739] INFO: Resolving twister.sbs.ohio-state.edu to 
128.146.194.91 took 0.002285 seconds
Jul 08 16:02:16 notifyme[27739] NOTE: NOTIFYME(twister.sbs.ohio-state.edu): OK

LDMPING OUTPUT FROM TWISTER2 TO TWISTER: 

[ldm@twister2 ~]$ ldmping twister.sbs.ohio-state.edu
Jul 08 16:03:12 INFO:      State    Elapsed Port   Remote_Host           
rpc_stat
Jul 08 16:03:12 INFO: Resolving twister.sbs.ohio-state.edu to 128.146.194.91 
took 0.00143 seconds
Jul 08 16:03:12 INFO: RESPONDING   0.003019  388   twister.sbs.ohio-state.edu  
Jul 08 16:03:37 INFO: RESPONDING   0.001562  388   twister.sbs.ohio-state.edu  
Jul 08 16:04:03 INFO: RESPONDING   0.265208  388   twister.sbs.ohio-state.edu  


I tried installing the LDM on my home computer and was able to send data from 
Twister (home computer is obviously outside of the firewall) 


Any help regarding the logging and/or connection is very much appreciated.  
Thanks for any help in advance -- back to searching the support archives...  


-- Phil Birnie
Department of Geography, The Ohio State University
(614)519-6176