[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[netCDF #FSG-396059]: error building netCDF C version 4.6.0



Yes, you need to include all the libraries needed.
This includes -lhdf5 -lhdf5_hl -lpnetcdf etc.
> 
> 
> I have downloaded netcdf 4.4.0 and netcdf 4.5.0. I do the same process( using 
> the same cppflags and ldflags) and I do not have any problem. I have not 
> tried yet to build it but I am not having this error anymore. It seems that 
> netcdf4.6 and netcdf4.6.1 have a bug.
> 
> 
> Regards,
> 
> 
> Estanis
> 
> ________________________________
> From: Estanislao Gavilan Pascual-Ahuir (PGR)
> Sent: 15 April 2018 20:10:18
> To: address@hidden
> Subject: Re: [netCDF #FSG-396059]: error building netCDF C version 4.6.0
> 
> 
> I do not call those libraries, they are called by netcdf. Do you think I 
> should add  -lhdf5 and -lhdf5_hl in my ldflags? I was able to install without 
> problems netcdf C with my hdf5 without using parallel netcdf.
> 
> All these problems appeared when I tried to build netcdf with parallel netcdf
> 
> 
> regards,
> 
> 
> Estanis
> 
> 
> ________________________________
> From: Unidata netCDF Support <address@hidden>
> Sent: 15 April 2018 19:58:34
> To: Estanislao Gavilan Pascual-Ahuir (PGR)
> Cc: address@hidden
> Subject: [netCDF #FSG-396059]: error building netCDF C version 4.6.0
> 
> From the config.log, it looks like your hdf5 is misconfigured.
> I see this:
> > mpicc ...  -L/mnt/nfs/home/b4064989/library/zlib/lib 
> > -L/mnt/nfs/home/b4064989/library/hdf5/lib 
> > -L/mnt/nfs/home/b4064989/library/netcdf4-parallel/lib conftest.c -lhdf5dll  
> > -ldl -lm -lz -lcurl
> 
> That reference to -lhdf5dll seems incorrect. It probably should be
> something like -lhdf5. Also, you appear to be missing -lhdf5_hl
> 
> Also, somewhere in the output you should have seen something like:
> > H5Flush not found
> indicating that your hdf5 library is not accessible.
> 
> 
> > I attack you the config file. I might have  missed something. Thanks so 
> > much for your time
> >
> > ________________________________
> > From: Unidata netCDF Support <address@hidden>
> > Sent: 15 April 2018 19:32:34
> > To: Estanislao Gavilan Pascual-Ahuir (PGR)
> > Cc: address@hidden
> > Subject: [netCDF #FSG-396059]: error building netCDF C version 4.6.0
> >
> > Ok, it is unclear what is happening. Can you post the config.log
> > you get from building netcdf-c?
> >
> > > This what it is inside the file
> > >
> > > #define PNETCDF_VERSION_MAJOR 1
> > > #define PNETCDF_VERSION_MINOR 9
> > >
> > >
> > > ________________________________
> > > From: Unidata netCDF Support <address@hidden>
> > > Sent: 15 April 2018 19:02:29
> > > To: Estanislao Gavilan Pascual-Ahuir (PGR)
> > > Cc: address@hidden
> > > Subject: [netCDF #FSG-396059]: error building netCDF C version 4.6.0
> > >
> > > ok. It may be that our test for version is flawed.
> > > Look at the file pnetcdf.h (probably in /usr/include or 
> > > /usr/local/include)
> > > and see what values it assigns to these
> > > PNETCDF_VERSION_MAJOR
> > > and
> > > PNETCDF_VERSION_MINOR;
> > >
> > > >
> > > >
> > > > I am using the last version 1.9.0. I downloaded it from here:
> > > >
> > > >
> > > > http://cucis.ece.northwestern.edu/projects/PnetCDF/download.html
> > > >
> > > > PnetCDF Source Code Download - Northwestern 
> > > > University<http://cucis.ece.northwestern.edu/projects/PnetCDF/download.html>
> > > > cucis.ece.northwestern.edu
> > > > PnetCDF Source Code Download The latest stable release of PnetCDF is 
> > > > version 1.9.0. Release of PnetCDF version 1.9.0 (December 19, 2017)
> > > >
> > > >
> > > >
> > > >
> > > > Regards,
> > > >
> > > >
> > > > Estanis
> > > >
> > > > ________________________________
> > > > From: Unidata netCDF Support <address@hidden>
> > > > Sent: 15 April 2018 18:52:58
> > > > To: Estanislao Gavilan Pascual-Ahuir (PGR)
> > > > Cc: address@hidden
> > > > Subject: [netCDF #FSG-396059]: error building netCDF C version 4.6.0
> > > >
> > > > What version of pnetcdf are you using?
> > > > If it is less than 1.6.0, then can you get your
> > > > system administrator to upgrade to pnetcdf
> > > > version 1.6.0 or later?
> > > >
> > > > >
> > > > > I am trying to compile netcdf C with pnetcdf. I have already installed
> > > > > netcdf parallel version 1.9 without any problem. However, if I try to
> > > > > configure netcdf C I have the error,  error: --enable-pnetcdf requires
> > > > > version 1.6.0 or later. I am using these commands to build netcdf C .
> > > > >
> > > > > Thanks advance for all help
> > > > >
> > > > >
> > > > > export CC=mpicc
> > > > >
> > > > > export FC=mpif90
> > > > >
> > > > > export CXX=mpicxx
> > > > >
> > > > >
> > > > > CPPFLAGS="-I/mnt/nfs/home/b4064989/library/zlib/include 
> > > > > -I/mnt/nfs/home/b4064989/library/hdf5/include 
> > > > > -I/mnt/nfs/home/b4064989/library/netcdf4-parallel/include" 
> > > > > LDFLAGS="-L/mnt/nfs/home/b4064989/library/zlib/lib 
> > > > > -L/mnt/nfs/home/b4064989/library/hdf5/lib 
> > > > > -L/mnt/nfs/home/b4064989/library/netcdf4-parallel/lib" ./configure 
> > > > > --prefix=/mnt/nfs/home/b4064989/library/netcdf4 --enable-netcdf-4 
> > > > > --enable-pnetcdf --disable-shared
> > > > >
> > > > >
> > > > > Kind regards,
> > > > >
> > > > >
> > > > > Estanis
> > > > >
> > > > >
> > > > >
> > > >
> > > > =Dennis Heimbigner
> > > > Unidata
> > > >
> > > >
> > > > Ticket Details
> > > > ===================
> > > > Ticket ID: FSG-396059
> > > > Department: Support netCDF
> > > > Priority: Normal
> > > > Status: Open
> > > > ===================
> > > > NOTE: All email exchanges with Unidata User Support are recorded in the 
> > > > Unidata inquiry tracking system and then made publicly available 
> > > > through the web.  If you do not want to have your interactions made 
> > > > available in this way, you must let us know in each email you send to 
> > > > us.
> > > >
> > > >
> > > >
> > > >
> > >
> > > =Dennis Heimbigner
> > > Unidata
> > >
> > >
> > > Ticket Details
> > > ===================
> > > Ticket ID: FSG-396059
> > > Department: Support netCDF
> > > Priority: Normal
> > > Status: Open
> > > ===================
> > > NOTE: All email exchanges with Unidata User Support are recorded in the 
> > > Unidata inquiry tracking system and then made publicly available through 
> > > the web.  If you do not want to have your interactions made available in 
> > > this way, you must let us know in each email you send to us.
> > >
> > >
> > >
> > >
> >
> > =Dennis Heimbigner
> > Unidata
> >
> >
> > Ticket Details
> > ===================
> > Ticket ID: FSG-396059
> > Department: Support netCDF
> > Priority: Normal
> > Status: Open
> > ===================
> > NOTE: All email exchanges with Unidata User Support are recorded in the 
> > Unidata inquiry tracking system and then made publicly available through 
> > the web.  If you do not want to have your interactions made available in 
> > this way, you must let us know in each email you send to us.
> >
> >
> >
> >
> 
> =Dennis Heimbigner
> Unidata
> 
> 
> Ticket Details
> ===================
> Ticket ID: FSG-396059
> Department: Support netCDF
> Priority: Normal
> Status: Open
> ===================
> NOTE: All email exchanges with Unidata User Support are recorded in the 
> Unidata inquiry tracking system and then made publicly available through the 
> web.  If you do not want to have your interactions made available in this 
> way, you must let us know in each email you send to us.
> 
> 
> 
> 

=Dennis Heimbigner
  Unidata


Ticket Details
===================
Ticket ID: FSG-396059
Department: Support netCDF
Priority: Normal
Status: Open
===================
NOTE: All email exchanges with Unidata User Support are recorded in the Unidata 
inquiry tracking system and then made publicly available through the web.  If 
you do not want to have your interactions made available in this way, you must 
let us know in each email you send to us.



NOTE: All email exchanges with Unidata User Support are recorded in the Unidata inquiry tracking system and then made publicly available through the web. If you do not want to have your interactions made available in this way, you must let us know in each email you send to us.