[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[LDM #APJ-776066]: new noaaport install



Hi Brendon,

I suspect that your O/S isn't allowing the UDP packets to be
received. You can verity this with tcpdump(1):

    tcpdump -i <<interface>> udp

If this shows something, then the Novra is likely working correctly but the
O/S is preventing noaaportIngester(1) from receiving the packets.

Tom will likely have more to say on this.

> Having trouble getting ldm 6.13.6 + noaaport installed on a new CentOS
> 7.3.1611 system (replacing an existing system).  I built ldm from source
> using the --with-noaaport option during the configure process.  ldm
> appears to have built successfully.  I can request & obtain data from
> idd.unidata.ucar.edu without issue.  But I'm not able to ingest from our
> novra receiver.  I modified ldmd.conf adding the following entries:
> EXEC    "noaaportIngester -m 224.0.1.1"
> EXEC    "noaaportIngester -m 224.0.1.2"
> EXEC    "noaaportIngester -m 224.0.1.3"
> EXEC    "noaaportIngester -m 224.0.1.4"
> EXEC    "noaaportIngester -m 224.0.1.5"
> EXEC    "noaaportIngester -m 224.0.1.6"
> EXEC    "noaaportIngester -m 224.0.1.7"
> EXEC    "noaaportIngester -m 224.0.1.8"
> 
> For the network configuration for the NIC attached to the novra:
> address@hidden network-scripts]$ more ifcfg-Wired_connection_2
> HWADDR=48:4D:7E:CA:BC:80
> TYPE=Ethernet
> BOOTPROTO=static
> IPADDR=192.168.1.5
> BROADCAST=192.168.1.255
> NETMASK=255.255.255.0
> NETWORK=192.168.1.0
> ADDRESS0=224.0.1.1
> NETMASK0=255.255.255.255
> ADDRESS2=224.0.1.2
> NETMASK2=255.255.255.255
> ADDRESS3=224.0.1.3
> NETMASK3=255.255.255.255
> ADDRESS4=224.0.1.4
> NETMASK4=255.255.255.255
> ADDRESS5=224.0.1.5
> NETMASK5=255.255.255.255
> ADDRESS6=224.0.1.6
> NETMASK6=255.255.255.255
> ADDRESS7=224.0.1.7
> NETMASK7=255.255.255.255
> ADDRESS8=224.0.1.8
> NETMASK8=255.255.255.255
> #PREFIX=32
> #DEFROUTE=yes
> IPV4_FAILURE_FATAL=no
> #IPV6INIT=yes
> #IPV6_AUTOCONF=yes
> #IPV6_DEFROUTE=yes
> #IPV6_PEERDNS=yes
> #IPV6_PEERROUTES=yes
> #IPV6_FAILURE_FATAL=no
> #IPV6_ADDR_GEN_MODE=stable-privacy
> NAME="Wired connection 2"
> UUID=1c8977d2-ed3b-3b07-8576-f82792116ce7
> ONBOOT=yes
> #AUTOCONNECT_PRIORITY=-999
> 
> I also edited /etc/sysctl.conf to add the following (matching what we
> had on our original system):
> net.ipv4.ipfrag_max_dist = 0
> net.ipv4.conf.default.rp_filter = 2
> 
> I can ping the novra receiver successfully.  The novra works fine with
> our old noaaport workstation, so I'm guessing I'm just missing something
> in either the ldmd.conf configuration or network configuration.  I keep
> comparing the old workstation config with the new and I'm struggling to
> find if I've missed anything else.  The ldm logs don't have anything
> useful, even when I start with the -v option; I see nothing coming
> across when I do a ldmadmin watch.  Any help is greatly appreciated.

Regards,
Steve Emmerson

Ticket Details
===================
Ticket ID: APJ-776066
Department: Support LDM
Priority: Normal
Status: Closed
===================
NOTE: All email exchanges with Unidata User Support are recorded in the Unidata 
inquiry tracking system and then made publicly available through the web.  If 
you do not want to have your interactions made available in this way, you must 
let us know in each email you send to us.



NOTE: All email exchanges with Unidata User Support are recorded in the Unidata inquiry tracking system and then made publicly available through the web. If you do not want to have your interactions made available in this way, you must let us know in each email you send to us.