[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[LDM #JHL-473805]: A problem of updating ldm version 4 to ldm version 6



Ross,

> According to the information on the webside, LDM 5.0.2 is the last version
> that is interoperable with LDM-4.
> Could you give me some hints about the major reason of why the newer version
> of LDM is not nteroperable with LDM-4.
> Is it about the updating of message queue or changing of RPC or something
> else?

The LDM uses ONC RPC for communication. That system requires that each version 
of the protocol (4, 5, 6, etc.) have its own dispatch engine to interpret the 
messages. In developing LDM-6, the LDM-4 engine was stripped-out because 1) the 
cost of keeping it in was considered greater than the benefit that would 
result; and 2) to give uses an additional incentive to upgrade their LDM.

> Thank you for your kindly help.
> Best Regard,
> Ross Lai


Regards,
Steve Emmerson

Ticket Details
===================
Ticket ID: JHL-473805
Department: Support LDM
Priority: Normal
Status: Closed


NOTE: All email exchanges with Unidata User Support are recorded in the Unidata inquiry tracking system and then made publicly available through the web. If you do not want to have your interactions made available in this way, you must let us know in each email you send to us.